Results 1 to 3 of 3

Thread: 4870 locking up on xorg-video-ati

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    89

    Default 4870 locking up on xorg-video-ati

    I have an Sapphire HD4870 works great with latest closed src driver but the video driver locks up when using 6.12.2 open src driver.
    The lock up occurs always when the windowmanager first maps the screen when the server starts up.
    System is running debian testing with the apropriate packages hand installed from unstable.

    Note: the kernel and everything else runs OK only the keyboard and video do not function.

    Is there anything required in the xorg.conf file for this.

    When the OS driver was tried the closed src was completely removed to stop it interfereing.

  2. #2
    Join Date
    Dec 2007
    Posts
    2,276

    Default

    File a bug (https://bugs.freedesktop.org) and attach your xorg log and config. Also, double check to make sure all the files changed by fglrx have be replaced by their open source versions and that the fglrx drm modules are removed.

  3. #3
    Join Date
    Nov 2008
    Posts
    89

    Default

    Thanks for the response agd5f, I was not sure if it was a bug or a feature so I had not done to much work on it. I shall put much more effort into the problem and I will see what happens.
    I did not double check on fglrx's removal, I also did not reboot after removing fglrx (I think) which could have left stale stuff around.
    Thanks for your help :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •