Results 1 to 3 of 3

Thread: Suspend, Resume, Play Video with XV => ASIC hang

  1. #1
    Join Date
    Aug 2008
    Posts
    22

    Question Suspend, Resume, Play Video with XV => ASIC hang

    Hi!

    I recently diagnosed a interesting bug:

    With a fresh booted box I can watch any Video with
    mplay -vo=xv

    No problem.
    As soon as I do a suspend/resume cycle and try the same fglrx will produce a nice (well not so nice ASIC hang and I need to login remotely to reboot my box.

    If I use -vo=gl2 mplayer plays the same video without any problem!?

    Some other intresting thing is: The Bug trace from asic hang mentions something like "reiserfs_rename"

    But I dont use reiserfs! All my partions are ext4..

    This is not realy critical as I know the work-around.. but perhaps interesting for some dev

  2. #2
    Join Date
    Feb 2009
    Posts
    23

    Default

    I cant reproduce it on my own box. I play some video over xv with mplayer-gui. While playback i switched to suspend. After wakeup the video plays back again flawlessly. Of course from the same position. Sound and Video!

    I'm using 4670 + catalyst 9.5

  3. #3
    Join Date
    Aug 2008
    Posts
    22

    Default

    Suspend to disk, or to ram?
    I didn't mean suspend _while_ watching video but more like:
    1. Startup
    2. do something (watch video, surfing gaming.. doesn't matter)
    3. suspend to disk
    4. wakeup
    5. watch video with mplayer --vo=xv
    --> Crash

    Ah, and my setup is a 4850 + catalyst 9.5
    Can this be related to me not having xserver 1.6 ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •