Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Xv on R600

  1. #1
    Join Date
    Mar 2009
    Posts
    27

    Default Xv on R600

    I have Radeon HD2600 card, and ive instaled xf86-video-ati 6.12.2, ati-dri 7.4.2, mesa 7.4.2, kernel 2.6.29.4.

    Unfortunately i cannot get Xv video
    Code:
    X-Video Extension version 2.2
    screen #0
     no adaptors present
    In X log i get error:
    Code:
    └─[$]> cat /var/log/Xorg.0.log | grep EE
    Current Operating System: Linux dinth-archlinux 2.6.29-ARCH #1 SMP PREEMPT Wed May 20 07:06:02 UTC 2009 i686
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) Failed to load module "freetype" (module does not exist, 0)
    (EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
    (EE) RADEON(0): Acceleration initialization failed
    It is possible get Xv video now, without using svn builds on R600 card ?

  2. #2
    Join Date
    Jan 2009
    Location
    Columbus, OH, USA
    Posts
    323

    Default

    Quote Originally Posted by Dinth View Post
    It is possible get Xv video now, without using svn builds on R600 card ?
    To my knowledge, no it is not. As I recall, it's actually the kernel DRM that is in the way. I've personally been using the r6xx-67xx-support branch for a while, though hopefully that will end soon. (Maybe as soon as next week? I've not been following things too close of late.)

  3. #3
    Join Date
    Aug 2007
    Posts
    6,675

    Default

    You need drm update or kernel 2.6.30.

  4. #4
    Join Date
    Sep 2008
    Posts
    201

    Default

    what is Ubuntu Jaunty using?

  5. #5
    Join Date
    Oct 2008
    Posts
    52

    Default

    He is using Arch-Linux.

    @Dinth: Install a package from AUR: http://aur.archlinux.org/packages.php?ID=24235 . This package build new drm kernel modules without overwriting the old ones.
    And you have to enable EXA and DRI in the xorg.conf.

  6. #6
    Join Date
    Oct 2008
    Posts
    52

    Default

    He is using Arch-Linux.

    @Dinth: Install this package from AUR: http://aur.archlinux.org/packages.php?ID=24235 . This package build new kernel modules without overwriting the old ones.
    And you have to enable EXA and DRI in the xorg.conf.

  7. #7
    Join Date
    Mar 2009
    Posts
    27

    Default

    Thanks very much i will test it. Must i add something to rc.conf for this ?

  8. #8
    Join Date
    Oct 2008
    Posts
    52

    Default

    Quote Originally Posted by Dinth View Post
    Thanks very much i will test it. Must i add something to rc.conf for this ?
    No, it installs the modules in the updates folder. They will automatically be used. If you want to use the old modules remove the package.

  9. #9
    Join Date
    Mar 2009
    Posts
    27

    Default

    Quote Originally Posted by Perry3D View Post
    No, it installs the modules in the updates folder. They will automatically be used. If you want to use the old modules remove the package.
    I finally get Xv to work. Unfortunately, desktop effects in KDE4 still dont work (i have DRI enabled in xorg.conf)

    Code:
    (II) AIGLX: Screen 0 is not DRI2 capable
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 10, (OK)
    drmOpenByBusid: Searching for BusID pci:0000:01:00.0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 10, (OK)
    drmOpenByBusid: drmOpenMinor returns 10
    drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
    (EE) AIGLX error: Calling driver entry point failed(EE) AIGLX: reverting to software rendering
    Last edited by Dinth; 06-07-2009 at 10:06 AM.

  10. #10
    Join Date
    May 2007
    Posts
    352

    Default

    r600 cards do not have 3D acceleration with the open source drivers, at least not in any form usable for end-users.

    Adam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •