Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: ATI drivers fglrx 8.35.5 and 8.34.8 fail

  1. #1
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default ATI drivers fglrx 8.35.5 and 8.34.8 fail

    I have a AMD64 TI6420 Emachine 2 gigs ram I am using Sidux
    Linux NewGpaSidux 2.6.20.5-rc1-slh-up-1 #1 Sun Apr 1 17:09:21 CEST 2007 i686 GNU/Linux
    I used du-fixes-h2.sh script in init 3 mode to update to the Kernel listed above then I decided to try the new driver 8.35.5 the install finished with no errors however when I tried to startx it cleared the screen and left me with a blinking cursor in the upper left hand corner, I tried 8.34.8 with the same result, each time having to reboot and getting back to the init 3, I also tried aticonf --initial and it reported back nothing to do. I recovered by replacing the Xorg.conf with a copy of the original. I was given www.phoronix.net as a possible source for additional tests or fixs from the sidux forum. please advise if you need additional information, thanking you in advance for your review.

  2. #2

    Default

    Quote Originally Posted by wirechief View Post
    I have a AMD64 TI6420 Emachine 2 gigs ram I am using Sidux
    Linux NewGpaSidux 2.6.20.5-rc1-slh-up-1 #1 Sun Apr 1 17:09:21 CEST 2007 i686 GNU/Linux
    I used du-fixes-h2.sh script in init 3 mode to update to the Kernel listed above then I decided to try the new driver 8.35.5 the install finished with no errors however when I tried to startx it cleared the screen and left me with a blinking cursor in the upper left hand corner, I tried 8.34.8 with the same result, each time having to reboot and getting back to the init 3, I also tried aticonf --initial and it reported back nothing to do. I recovered by replacing the Xorg.conf with a copy of the original. I was given www.phoronix.net as a possible source for additional tests or fixs from the sidux forum. please advise if you need additional information, thanking you in advance for your review.

    Does the SIDUX script include the Linux 2.6.20 patch? Otherwise that would likely be your problem though it should have given you errors during the build process. Do you know off hand how SIDUX handles the build and install process of the fglrx module?

    Also, what is the output of: cat /var/log/Xorg.0.log | grep EE

  3. #3
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    I thought I saw something about a Patch being applied, everything moved so fast, that was on the newest driver but the older driver i didnt see anything about a patch.
    I also tried to use the manual install but cant remember the correct command it resulted in the same however no errors while processing but when xserver was started it failed the same way.

    root@NewGpaSidux:/home/Wirechief# cat /var/log/Xorg.0.log | grep EE
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) AIGLX: Screen 0 is not DRI capable
    root@NewGpaSidux:/home/Wirechief# Reply With Quote

    that was the result.
    I don't know how the script process's anything, it works very nicely, I got the Kernel listed and then decided to try the fglrx 8.35.5 I have been advised by H2 (forum moderator) that perhaps a different Kernel would work, if running the script
    for Sidux can do that I will give it a try.
    Last edited by wirechief; 04-02-2007 at 12:08 PM.

  4. #4

    Default

    For your AIGLX error, in your xorg.conf append:

    Section "Extensions"
    Option "Composite" "Disable"
    Option "AIGLX" "Disable"
    EndSection

  5. #5
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    Section "Extensions"
    # Option "Composite" "1"
    # Option "RENDER" "1"
    EndSection

    I am new to this, do i change "1" to "disable" for Composite? and what about that other option, it is not shown.

  6. #6
    Join Date
    Nov 2006
    Posts
    102

    Default

    Replace this:

    Code:
    # Option "Composite" "1"
    # Option "RENDER" "1"
    with this:

    Code:
      Option "Composite" "disable"
      Option "RENDER" "disable"

  7. #7
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    Now here is where I get into trouble, my editors, Kate Kedit and Kwrite are refused by the server. Seems I need permissions? (this is a new install of Sidux) not sure what the best route to do this is and I know its out of the area of this thread. So until I can do that I will not be able to change that.

  8. #8
    Join Date
    Mar 2007
    Posts
    36

    Default

    So is the current correct syntax for xorg.conf for fglrx this:?

    Option "Composite" "Disable"
    Option "Render" "Disable"
    Option "AIGLX" "Disable"

    What is the 'enable' in that case? "Enable", "On", or something else?

    Are all 3 required, or is AIGLX optional to disable?

    Is the default then 'On'|'Enable' which it would seem to be if you need to explicitly state that it is disabled, not just commenting out the line.

    This syntax difference only appears to be an issue with 64 bit fglrx drivers from what I can see, but might as well get it technically accurate to maximize odds of fglrx actually working.
    Last edited by gfxdrone; 04-02-2007 at 03:46 PM.

  9. #9
    Join Date
    Mar 2007
    Posts
    36

    Default

    wirechief, you have to edit these as root, su.

    You can use something like mcedit in terminal to do that.

    su to root, login, then: mcedit /etc/X11/xorg.conf

    do the edits, save, then restart x.

    Or run your GUI text editors as root. In KDE, right click desktop, choose run command, click options, run as different user, root, with password, kwrite as command. Open file, edit, save.

    Since you can't get into x, you can't use x gui editors, of course. So use mcedit.

    If editing in console and that stuff is a mystery to you, I strongly suggest you not use 64 bit, you will not benefit from it.

  10. #10
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    51

    Default

    Quote Originally Posted by gfxdrone View Post
    wirechief, you have to edit these as root, su.

    You can use something like mcedit in terminal to do that.

    su to root, login, then: mcedit /etc/X11/xorg.conf

    do the edits, save, then restart x.

    Or run your GUI text editors as root. In KDE, right click desktop, choose run command, click options, run as different user, root, with password, kwrite as command. Open file, edit, save.

    Since you can't get into x, you can't use x gui editors, of course. So use mcedit.

    If editing in console and that stuff is a mystery to you, I strongly suggest you not use 64 bit, you will not benefit from it.
    Thank you for this great information, I will add it to my tool bag.
    When I saw the install putting 64bit driver in, I groaned, I have had lots of trouble with them, the process is autoamted I did not manually download the driver, this is all a learning process for me. I did get help from the IRC and used sux in a new terminal session and have made the changes, I am just getting ready to re-run the code given by Michael
    I was able to recover by replacing the bad Xorg.conf with my saved copy of the original but still knowing about mcedit is very very helpfull again thank you.
    Last edited by wirechief; 04-02-2007 at 04:58 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •