Results 1 to 6 of 6

Thread: Ubuntu Defaults To Intel Kernel Mode-Setting

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    14,601

    Default Ubuntu Defaults To Intel Kernel Mode-Setting

    Phoronix: Ubuntu Defaults To Intel Kernel Mode-Setting

    Canonical's X.Org guy, Bryce Harrington, has announced the switch to using Intel kernel mode-setting by default beginning with the new Linux 2.6.30 kernel update that was just committed to the Ubuntu 9.10 "Karmic Koala" repository. Cheers! For those unfamiliar with what Intel kernel mode-setting means or would like more information, check out the mailing list announcement...

    http://www.phoronix.com/vr.php?view=NzM0Mw

  2. #2
    Join Date
    Dec 2007
    Posts
    677

    Default

    So all people enjoying decent graphcis drivers (movies/compiz/gaming) are screwed by default in the next version?

  3. #3
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    This refers to

    http://kernel.ubuntu.com/git?p=ubunt...dcc6460e958d2c

    But i still have to test what happens when the xserver/driver is too old for kms.

  4. #4
    Join Date
    Jun 2006
    Posts
    24

    Default

    It makes my system unbootable with the latest kernel update. So beware to everyone not having a intel gfx card. Hopefully it'll get fixed soon.

  5. #5
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    Without intel card the change has nothing to do with it. Do you have got a saa7146 card in your pc?

    lspci -nn|grep 7146

  6. #6
    Join Date
    Jun 2006
    Posts
    24

    Default

    Quote Originally Posted by Kano View Post
    Without intel card the change has nothing to do with it. Do you have got a saa7146 card in your pc?

    lspci -nn|grep 7146
    No. To be fair it fails with busybox. If I just exit that it continues to boot. Others have reported that that doesn't happen if you disable modesetting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •