My system used to run opensuse11.0 with the fglrx drivers perfectly happily. I had to reinstall due to a dead hard drive, and found that after installing opensuse11.1 I can't get any video after installing the fglrx driver. I have since tried to install 11.0 again and get the same problem, so I don't think it's a difference between 11.0 and 11.1. The card is an AGP ATi Radeon 2600HD Pro.

My monitor's native resolution is 1024x768 and it runs fine at 60, 70 and 75Hz. With a fresh install of opensuse using radeonhd drivers it displays fine at 1024x768. If I download the ATi driver install run file directly from AMD's site, it runs fine and all appears to have worked. When I run aticonfig –initial all seems to be OK until I restart X, at which point my monitor shows “out-of-range”. If I then reboot to runlevel 3 and restore the old xorg.conf that worked fine before the fglrx drivers were loaded, all I get is a blank screen when I start X.

I have tried quite a few different methods of installing the drivers, and spent a lot of time trying to tweak xorg.conf to get a display with fglrx, and my results are all in a thread on linuxquestions.org: here.

Given that a known-good xorg.conf still failed after the fglrx drivers went in, can anyone tell me what else has changed? There must be some other configuration files I am missing that went in with fglrx.

Any help much appreciated.