Results 1 to 7 of 7

Thread: ATI 4850 dual head, big desktop fail to wake up

  1. #1
    Join Date
    Jul 2009
    Posts
    4

    Exclamation ATI 4850 dual head, big desktop fail to wake up

    I am running Ubuntu Jaunty with a ATI 4850 in big desktop mode (done using amdcccle). ATI driver version 9.6

    The problem is that every time my display goes to sleep, the card crashes. I can still ssh into the box but X is dead. So the screen does not wake up and I have to reboot.

    There is nothing interesting syslog or kern.log, Xorg.0.log or .xsession-errors.

    This is very annoying. Any ideas?

    Some of the possibly relevant errors:
    kern.log
    [fglrx] DRM MCIL: MCIL_QuerySystemInfo command :4 not implement

  2. #2
    Join Date
    Mar 2009
    Posts
    175

    Default

    Do you have compiz/beryl desktop effects enabled? If so disable them in Preferences->Appearances->Visual Effects.

    Fixed the problem for me with a 4850 mobility in my GT725, sucks, but ATI drivers blow hard for linux as in an advert for nVidia. I still get lockups when playing back video after awaking from sleep though.

    As to the error, yeah I still see that in my logs as well, but it doesn't seem to cause any problems AFAIK, and turning off the desktop effects did the trick for me.

    [EDIT]
    At the time of the problem (and now) I never had a second machine to attempt to ssh in with, so I can't verify if the system was still up here w/X locked. But, have you tried killing the X server process, and then re-starting X?

    (Not much of a solution for me anyways even if it works as the entire point of a notebook is to have a single mobile platform which generally implies no other machine capable of sshing to effect the workaround.)
    [/EDIT]
    Last edited by cutterjohn; 07-02-2009 at 10:17 AM.
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  3. #3
    Join Date
    Jul 2009
    Posts
    4

    Thumbs up

    Do you have compiz/beryl desktop effects enabled? If so disable them in Preferences->Appearances->Visual Effects.
    Ok, this seems to have fixed the problem for me as well. Thanks!

    ssh into the box didn't help much because the card crashed and not the CPU. So restarting X didn't help, I had to shutdown the box.
    -Z:

  4. #4
    Join Date
    Jul 2009
    Posts
    4

    Thumbs down Big desktop gone

    The only issue that now remains is that when the screen wakes up from sleep, the amdcccle big desktop settings are lost and it mirrors both displays.

    Any idea how to make this setting persistent?

    Z

  5. #5
    Join Date
    Mar 2009
    Posts
    175

    Default

    Sorry, not a clue as these drivers are beyond awful.

    Maybe try in the current catalyst 9.6 released thread? Bridgman might respond and have some workarounds for you.

    (I honestly can never recall having so many gfx driver problems with linux/X in over 15y of use on x86/ppc as I have with ATI GPUs & proprietary drivers... The big headache back in the day was tracking down the refresh rates for your monitor to generate the modelines properly... At least the Windows drivers are OK although they have other problems there given that ATI actually sells their own complete cards as well as the GPU itself...)
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,285

    Default

    Actually we sell hardware the same way irrespective of OS; we sell chips to partners, they make and sell boards.

    Zorgo, can you please file a ticket at ati.cchtml.com ?

  7. #7
    Join Date
    Jul 2009
    Posts
    4

    Default Still not working

    Here is the bug link http://ati.cchtml.com/show_bug.cgi?id=1596

    Sadly this issue is really crippling. I find that the computer is nearly not usable (if I leave the PC switched on and switch the monitors off, then the graphics card goes to sleep by itself with the result of a broken wakeup).

    At worst, I have a crashed machine in the morning, at best I have to ctrl-alt-backspace to restart X. This is even if I disable power saving in X.

    Am I alone on this? Dual head on the 4850 is just not usable at the moment.

    Question: Why does the Open Source drivers not work at all on this card? Anybody else seen a garbled screen on startup with any driver other than the proprietary or vesa?

    ZP

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •