Results 1 to 3 of 3

Thread: Permanent X setup with Xrandr 1.2.99 on Fedora 11

  1. #1
    Join Date
    Nov 2007
    Posts
    117

    Default Permanent X setup with Xrandr 1.2.99 on Fedora 11

    I have a mini-ITX system with a core 2 duo (laptop) CPU and an i915 chipset on which I just installed Fedora 11.

    kernel: 2.6.29.5-191.fc11.i686.PAE
    libXrandr-1.2.99.4-3.fc11.i586
    libXrandr-devel-1.2.99.4-3.fc11.i586

    The graphics is a bit messed up. The chipset and motherboard support LVDS, but I do not have a display hooked up to the LVDS. I have a 1280x1024 LCD monitor hooked up to the VGA (HD15) connector.
    Because the X server detects the LVDS, X windows comes up in 800x600 resolution.

    I would like to set it so that the LVDS is turned off and only the VGA output is turned on, at 1280x1024 resolution. I notice there is no /etc/X11/xorg.conf file any more. How do I create an xorg.conf file, or equivalent, to accomplish this?

    TIA

  2. #2
    Join Date
    Nov 2008
    Posts
    38

    Default

    'Xorg -configure' will make you an xorg.conf. Read 'man intel' to learn about the option ("Ignore" should interest you).

  3. #3
    Join Date
    Nov 2007
    Posts
    117

    Smile

    Excellent, thank you.

    "Ignore" is actually covered in the xorg.conf man page, not the intel man page.

    I added this to my new xorg.conf file:

    -------------
    Section "Monitor"
    Identifier "LVDS1"
    Option "Ignore" "TRUE"
    EndSection

    Section "Monitor"
    Identifier "TV1"
    Option "Ignore" "TRUE"
    EndSection
    -------------

    And now only the VGA connection shows up.

    In addition, this somehow allows XVideo to work, which clears up my next problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •