Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: FOSS driver and X800

  1. #1
    Join Date
    Mar 2007
    Posts
    11

    Default FOSS driver and X800

    Hi. I've been following the articles covering the Free driver development, great stuff.

    I recently upgraded from a 9250 to an x800 (after issues with the old AGP motherboard...). I've got int working nicely, except that glxgears runs at ~70% CPU and ActionCube / Sauerbraten run so slow they are unplayable. DRI is enabled, and I've tried numerous xorg.conf arrangements.

    Is there anyone who uses the Free driver and an x800 who can give me some advice and a peak at their xorg.conf?

    Cheers
    =========
    Using Mesa 6.5.1, Xorg 7.1, radeon driver on fedora core 6.

  2. #2

    Default

    JonC,

    Welcome to the forums and hope you're here to stay on the forums

    Have you looked at http://dri.freedesktop.org/wiki/ATIR...33fee7003e858d for trying any of those xorg.conf options? I have used several R300 components under Linux, but I am trying to remember if I ever ran it with Sauerbraten. I know last year there were longstanding bugs with fglrx and Cube/Sauerbraten, but I do not know what problems exist for the open-source driver.

  3. #3
    Join Date
    Sep 2006
    Location
    PL
    Posts
    907

    Default

    i think i'll put my x300 back in and try with those settings.

    i had problems when experimenting with aiglx on free driver - slowness and lots of screen corruptions.

    some people claim that exa is way faster with those drivers. but i don't think it's safe to use yet.

  4. #4
    Join Date
    Mar 2007
    Posts
    11

    Default

    Hi, thanks.

    I tried those options a while ago. Some things improve performance, some degrade it, but always it runs at about 70% CPU just doing glxgears.

    Is this normal or is it dropping something back to software acceleration?

  5. #5

    Default

    Quote Originally Posted by JonC View Post
    Hi, thanks.

    I tried those options a while ago. Some things improve performance, some degrade it, but always it runs at about 70% CPU just doing glxgears.

    Is this normal or is it dropping something back to software acceleration?
    It's normal. As long as in games you are having acceleration, you should be set. Even when I run glxgears with the fglrx drivers the CPU will spike to full load as glxgears is really CPU dependent and really doesn't do much for modern GPUs.

  6. #6
    Join Date
    Mar 2007
    Posts
    11

    Default

    OK, thanks.

    Now all I need to do is find out what on earth is causing ActionCube and Sauerbraten to go to software mode, and I'll be set.

    Thanks very much.

  7. #7

    Default

    Try contacting Kurtis Kesler at kurtk84@fidmail.com

    He is a Sauerbraten developer (or something to that effect) and I had talked with him last year about Sauerbraten and ATI.

  8. #8
    Join Date
    Mar 2007
    Posts
    11

    Default

    Thanks Michael, I will.

    Honestly, thanks for being so helpful, it is really appreciated.

  9. #9

    Default

    Quote Originally Posted by JonC View Post
    Honestly, thanks for being so helpful, it is really appreciated.
    You're welcome; thanks for the kind comments. Be sure to come back to the Phoronix Forums!

  10. #10
    Join Date
    Mar 2007
    Posts
    11

    Default

    Just so people know, it looks like some of the functions for openGL haven't been implemented. A quick example is that some openGL screen savers are smooth as anything, while others are crippled and barely run.

    I'll try updating mesa to the latest git and post back any results.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •