Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ati m 9600 (RV350) with fglrx: xv does not work with compiz

  1. #1
    Join Date
    Jun 2009
    Posts
    10

    Default ati m 9600 (RV350) with fglrx: xv does not work with compiz

    Hello all,

    Does any have some idea how to play video on fullscreen with fglrx driver and running compiz?
    I tried to find a solution with google and these settings should help but don't:
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "on"

    another thread tell that but I know that it should work only for newer cards (>= R5xx)
    Option "TexturedVideo" "on"

    I tried also OpenGLOverlay off but it doesn't help either. I don't see anything at all, only dark-violet screen (even not fullscreened). In other case I see flicker.
    I also tried gl and gl2 but the system use to freeze in such case. I'm using the newest driver ati-drivers-8.593 and xorg-server-1.5.3-r6.
    Another issue which would be very helpful to solve is that I miss manual for fglrx. I know there are html pages in /usr/share/doc/ati-drivers-8.593/html/fglrx/ but they don't help at all. What I'm looking for is some manual for driver related Options in the Device section of xorg.conf. Something like "man radeon" which helps perfect in this way.

    Of course I also tried opensource driver but it doesn't work well. Only compiz works for me. Games are ver very slow (and FretsOnFire doesn't work at all) and thus not possible to play. I'm always getting "[driAllocateTexture:635] unable to allocate texture". I tried almost everything to get it to work properly (about 2 weeks of everyday's seeking on google and playing around with xorg.conf, lot of kernel settings, kernel versions, xorg server versions, ...)

    Please, any advice is welcome!

  2. #2
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"

    would be a working combination in theory.

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    If you're running with VideoOverlay on then the video won't go through the compositor; the overlay hardware "floats" the video image in front of the framebuffer. You need to use TexturedVideo if you want the video to go through the compositor.

    TexturedVideo should work for any supported card; we only default it on for 5xx and up AFAIK because 5xx and up don't have the older video overlay hardware with a full-blown video processor in the block. One common option is TexturedVideo with Compiz set to Unredirect Fullscreen Windows.

    OpenGLOverlay is only for specific workstation apps which float a menu over a full-screen worksurface. Turn it off.

  4. #4
    Join Date
    Jun 2009
    Posts
    10

    Default

    Quote Originally Posted by bridgman View Post
    If you're running with VideoOverlay on then the video won't go through the compositor; the overlay hardware "floats" the video image in front of the framebuffer. You need to use TexturedVideo if you want the video to go through the compositor.

    TexturedVideo should work for any supported card; we only default it on for 5xx and up AFAIK because 5xx and up don't have the older video overlay hardware with a full-blown video processor in the block. One common option is TexturedVideo with Compiz set to Unredirect Fullscreen Windows.

    OpenGLOverlay is only for specific workstation apps which float a menu over a full-screen worksurface. Turn it off.
    Thanks for your reply

    With these options:
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"

    ...I've got only dark-violet screened window as I wrote in the first post.

    As soon as I enable TexturedVideo and play video with running compiz my X crashes with SEGV signal and this error from dmesg:
    [ 1907.801977] [fglrx] It's not necessary to adjust system aperture on this ASIC
    [ 1909.555498] uhci_hcd 0000:00:1d.0: reserve dev 2 ep82-INT, period 8, phase 4, 118 us

    Enabling Unredirect Fullscreen Windows does not help at all.

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Which driver version are you using ? Can you pastebin an xorg log ?

  6. #6
    Join Date
    Jun 2009
    Posts
    10

    Default

    Of course I also tried with VideoOverlay off which is the same as with on. With gl and gl2 as the video output there is flicker so it's not composited.

  7. #7
    Join Date
    Jun 2009
    Posts
    10

    Default

    Quote Originally Posted by bridgman View Post
    Which driver version are you using ? Can you pastebin an xorg log ?
    I'm using 8.593 (9.3) and 2.6.28-gentoo-r5 kernel

    Xorg.0.log: http://pastebin.com/m6145717e

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Quote Originally Posted by luboss View Post
    Of course I also tried with VideoOverlay off which is the same as with on.
    Huh ? Are you missing an important word here ?

    Quote Originally Posted by luboss View Post
    With gl and gl2 as the video output there is flicker so it's not composited.
    With Cat 9.3 and later the GL output is composited and should be flicker-free.

  9. #9
    Join Date
    Jun 2009
    Posts
    10

    Default

    Quote Originally Posted by bridgman
    Which driver version are you using ? Can you pastebin an xorg log ?
    I'm using 8.593 version.
    Xorg.0.log: http://pastebin.com/m1903dae

    Quote Originally Posted by bridgman View Post
    Huh ? Are you missing an important word here ?
    I mean that it does not matter if VideoOverlay is off or on if TexturedVideo is enabled.

    Quote Originally Posted by bridgman View Post
    With Cat 9.3 and later the GL output is composited and should be flicker-free.
    I've got 9.3 and as I told gl2 flickers and stays in the center even if I'm rotating with the desktop cube.

  10. #10
    Join Date
    Jun 2009
    Posts
    10

    Default

    Quote Originally Posted by bridgman
    Which driver version are you using ? Can you pastebin an xorg log ?
    I'm using 8.593 version.
    Xorg.0.log: http://pastebin.com/m1903dae

    Quote Originally Posted by bridgman View Post
    Huh ? Are you missing an important word here ?
    I mean that it does not matter if VideoOverlay is off or on if TexturedVideo is enabled.

    Quote Originally Posted by bridgman View Post
    With Cat 9.3 and later the GL output is composited and should be flicker-free.
    I've got 9.3 and as I told gl2 flickers and stays in the center even if I'm rotating with the desktop cube.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •