@Leilei

Have you checked 'unlagged hitscan' in the options?
Nope, but if this helps why it's not enabled?