Results 1 to 5 of 5

Thread: radeon driver and 120 hz displays

  1. #1
    Join Date
    Oct 2009
    Posts
    3

    Default radeon driver and 120 hz displays

    I have a Samsung SyncMaster 2233RZ monitor which can do real 120 hz. When using the fglrx driver with my Radeon 4850, i can choose between 60, 100, 110 and 120 hz. However, when using the radeon driver, i can only select 60 hz.

    Here's the xrandr output:

    Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    VGA-0 disconnected (normal left inverted right x axis y axis)
    DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 478mm x 300mm
    1680x1050 59.9*+

    I'm using Ubuntu 9.10.

  2. #2
    Join Date
    Oct 2007
    Posts
    1,323

    Default

    Create a mode line using cvt:
    Code:
    cvt 1680 1050 120Hz
    It should return something like:
    Code:
    # 1680x1050 119.89 Hz (CVT) hsync: 135.24 kHz; pclk: 313.75 MHz
    Modeline "1680x1050_120.00"  313.75  1680 1816 2000 2320  1050 1053 1059 1128 -hsync +vsync
    Now add the mode using xrandr:
    Code:
    xrandr --newmode "1680x1050_120.00"  313.75  1680 1816 2000 2320  1050 1053 1059 1128 -hsync +vsync
    Change to the new mode:
    Code:
    xrandr --output DVI-0 --mode 1680x1050_120.00

  3. #3
    Join Date
    Oct 2009
    Posts
    3

    Default

    Thank you for your replay DanL. I had to add 'xrandr --addmode DVI-0 "1680x1050_120.00"' after the newmode because otherwise xrandr complained about an unknown mode.

    It didn't work tho :-( The mode changed successfully, but my monitor went black and i got an wrong mode message and had to restart :-(

  4. #4
    Join Date
    Oct 2009
    Posts
    3

    Default

    Update:

    KMS wasn't enabled by default. Enabling it brought me all the modes fglrx detected :-)

    Works quite well so far.. Desktop is smooth, ioq3 and smc both run fine. Got about 200fps in q3 with a 1680x1050 res and high gfx settings. Smc seems a bit choppy tho..

  5. #5
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by snkt View Post
    Thank you for your replay DanL. I had to add 'xrandr --addmode DVI-0 "1680x1050_120.00"' after the newmode because otherwise xrandr complained about an unknown mode.

    It didn't work tho :-( The mode changed successfully, but my monitor went black and i got an wrong mode message and had to restart :-(
    Just for reference cvt -r may have worked. The -r is for reduced blanking so the pixclock is lower.

    Code:
    bash-3.2$ cvt -r 1680 1050 120
    # 1680x1050 119.86 Hz (CVT) hsync: 133.29 kHz; pclk: 245.25 MHz
    Modeline "1680x1050R"  245.25  1680 1728 1760 1840  1050 1053 1059 1112 +hsync -vsync
    You'll need a recent cvt (part of xorg) as IIRC the older versions would only do -r if the refresh rate was 60Hz.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •