Results 1 to 7 of 7

Thread: Catalyst 9.3 + Big Desktop + Composite + 3D = System Freeze

  1. #1
    Join Date
    Jun 2009
    Location
    Calgary, Canada
    Posts
    5

    Default Catalyst 9.3 + Big Desktop + Composite + 3D = System Freeze

    In a nutshell:
    - Slackware 12.2 (custom kernel 2.6.29.4)

    - ATI Catalyst 9.3 (last that supports my 9800 Pro)

    - X.org server 1.4.2 (Slack12.2 pkg)

    - KDE 3.5 (Slack 12.2 pkg)

    - Dual monitor (working without Xinerama)

    - 3D 'works'...
    'fglrxinfo' output:
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON 9800 PRO
    OpenGL version string: 2.1.8543 Release

    'glxinfo | grep direct' output:
    direct rendering: Yes
    'glxgears' works w/ FPS between 1600-4200

    - Composite X extension disabled.

    Problems:

    - Turning Composite X extension on DOES result in appropriate desktop effects (transparency), but any 3D program (incl glxgears) hangs the system completely- requires a system reboot.

    - CPU load % goes WAY up while running 3D. Noticed specifically with glxgears, but Google Earth is also sluggish.

    My xorg.conf:
    Code:
    Section "ServerLayout"
            Identifier     "Simple Layout"
            Screen      0  "aticonfig-Screen[0]" 0 0
            InputDevice    "Mouse1" "CorePointer"
            InputDevice    "Keyboard1" "CoreKeyboard"
    EndSection
    
    Section "Files"
            FontPath     "/usr/X11/lib/X11/fonts/misc/"
            FontPath     "/usr/X11/lib/X11/fonts/TTF/"
            FontPath     "/usr/X11/lib/X11/fonts/OTF"
            FontPath     "/usr/X11/lib/X11/fonts/Type1/"
            FontPath     "/usr/X11/lib/X11/fonts/100dpi/"
            FontPath     "/usr/X11/lib/X11/fonts/75dpi/"
            FontPath     "/usr/X11/lib/X11/fonts/Speedo/"
            FontPath     "/usr/local/share/fonts/"
    EndSection
    
    Section "Module"
    
    #               Option      "omit xfree86-dga"   # don't initialise the DGA extension
    #       EndSubSection
            Load  "dbe"
            Load  "v4l"
            Load  "extmod"
            Load  "type1"
            Load  "freetype"
            Load  "GLcore"
            Load  "glx"
            Load  "dri"
            Load  "xtrap"
    #       SubSection "extmod"
    EndSection
    
    Section "ServerFlags"
            Option      "AIGLX" "on"
            Option      "Xinerama" "off"
    EndSection
    
    Section "InputDevice"
            Identifier  "Keyboard1"
            Driver      "kbd"
            Option      "AutoRepeat" "500 30"
    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
            Option      "XkbRules" "xorg"
            Option      "XkbModel" "pc105"
            Option      "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
            Identifier  "Mouse1"
            Driver      "mouse"
            Option      "Protocol" "ImPS/2"
            Option      "Device" "/dev/mouse"
            #Option     "Device" "/dev/psaux"
            Option      "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
    #       Option      "DPMS" "true"
            Option      "FlatPanelProperties" "Scaling=Centered"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[1]"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
    #       Option      "DPMS" "true"
            Option      "FlatPanelProperties" "Scaling=Centered"
    EndSection
    
    Section "Device"
            Identifier  "Standard VGA"
            Driver      "vga"
            VendorName  "Unknown"
            BoardName   "Unknown"
    EndSection
    
    Section "Device"
            Identifier  "aticonfig-Device[0]"
            Driver      "fglrx"
            Option      "AccelMethod" "EXA"
            Option      "MigrationHeuristic" "greedy"
            Option      "AccelDFS" "true"
            Option      "EnablePageFlip" "true"
            Option      "EnableDepthMoves" "true"
            Option      "DesktopSetup" "horizontal"
            Option      "no_accel" "no"
            Option      "no_dri" "no"
            Option      "mtrr" "off"
            Option      "Simple Layout" "off"
            Option      "IgnoreEDID" "off"
            Option      "HSync2" "unspecified"
            Option      "VRefresh2" "unspecified"
            Option      "ScreenOverlap" "0"
            Option      "Capabilities" "0x00008800"
            Option      "VideoOverlay" "on"
            Option      "OpenGLOverlay" "on"
            Option      "FSAAEnable" "yes"
            Option      "FSAAScale" "2"
            Option      "FSAADisableGamma" "no"
            Option      "FSAACustomizeMSPos" "no"
            Option      "FSAAMSPosX0" "0.000000"
            Option      "FSAAMSPosY0" "0.000000"
            Option      "FSAAMSPosX1" "0.000000"
            Option      "FSAAMSPosY1" "0.000000"
            Option      "FSAAMSPosX2" "0.000000"
            Option      "FSAAMSPosY2" "0.000000"
            Option      "FSAAMSPosX3" "0.000000"
            Option      "FSAAMSPosY3" "0.000000"
            Option      "FSAAMSPosX4" "0.000000"
            Option      "FSAAMSPosY4" "0.000000"
            Option      "FSAAMSPosX5" "0.000000"
            Option      "FSAAMSPosY5" "0.000000"
            Option      "UseFastTLS" "0"
            Option      "BlockSignalsOnLock" "on"
            Option      "EnablePrivateBackZ" "yes"
            Option      "MergedFB" "true"
            Option      "UseInternalAGPGART" "off"
            Option      "KernelModuleParm" "off"
    #       Option      "SWCursor" "on"
            Option      "Centermode" "on"
            BusID       "PCI:2:0:0"
    EndSection
    
    Section "Device"
    #       Option      "DesktopSetup" "0x00000000"
            Identifier  "aticonfig-Device[1]"
            Driver      "fglrx"
            Option      "FSAAEnable" "no"
            Option      "FSAAScale" "1"
            Option      "FSAADisableGamma" "no"
            Option      "FSAACustomizeMSPos" "no"
            Option      "FSAAMSPosX0" "0.000000"
            Option      "FSAAMSPosY0" "0.000000"
            Option      "FSAAMSPosX1" "0.000000"
            Option      "FSAAMSPosY1" "0.000000"
            Option      "FSAAMSPosX2" "0.000000"
            Option      "FSAAMSPosY2" "0.000000"
            Option      "FSAAMSPosX3" "0.000000"
            Option      "FSAAMSPosY3" "0.000000"
            Option      "FSAAMSPosX4" "0.000000"
            Option      "FSAAMSPosY4" "0.000000"
            Option      "FSAAMSPosX5" "0.000000"
            Option      "FSAAMSPosY5" "0.000000"
            Option      "EnablePrivateBackZ" "yes"
            BusID       "PCI:2:0:0"
            Screen      1
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[0]"
            Device     "aticonfig-Device[0]"
            Monitor    "aticonfig-Monitor[0]"
            DefaultDepth     24
            Option      "XaaNoOffscreenPixmaps" "true"
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1440x900"
            EndSubSection
    EndSection
    
    Section "Screen"
            Identifier "aticonfig-Screen[1]"
            Device     "aticonfig-Device[1]"
            Monitor    "aticonfig-Monitor[1]"
            DefaultDepth     24
            Option      "XaaNoOffscreenPixmaps" "true"
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes    "1440x900"
            EndSubSection
    EndSection
    
    Section "DRI"
    
    #       Group   "video"
            Mode         0666
    EndSection
    
    Section "Extensions"
    #       Option      "Damage" "Enable"
    #       Option      "Composite" "Enable"
    #       Option "Composite" "disable"
    EndSection
    I'd LOVE to enable Composite and still have my 3D work (I'd ultimately like to use compiz, though recent attempts don't *hang* the system, the resulting graphics are, um, 'garbled' and completely unusable). But so far I have been unable to find a configuration that works properly.
    I merely assume this is a limitation of the fglrx 9.3 driver and there likely isn't anything I can do about it by cry a little and vow to never own another ATI card again. Can anyone confirm my worst fears or is there something I might be able to try to make it work?

    Thanks,

    - skubik

  2. #2
    Join Date
    Jun 2009
    Location
    Calgary, Canada
    Posts
    5

    Default

    bump. Anyone with any insight?

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Any chance you could try with a kernel/distro we work with internally ? We know there are issues with 2.6.29 and above, so go with 2.6.28 or earlier for now...
    Last edited by bridgman; 07-04-2009 at 11:15 AM.

  4. #4
    Join Date
    Jun 2009
    Location
    Calgary, Canada
    Posts
    5

    Default

    Thanks bridgman,
    I downgraded my kernel to 2.6.28.9. Reinstalled the Catalyst 9.3 driver. Enabled Composte in my xorg.conf. Ran startx and....

    ... no difference.
    - Composite doesn't work at all (checked using Audacious's OCD plugin & KDE 'Window Behavior'.
    - Translucency tab in the Control Center).
    - 3D does work (tested glxgears & glmatrix screensaver- though *other* GL screensavers result in splotches of the screen having black 'artifacts' on them, terribly distorting the image being rendered), and even still- my CPU usage even when running glxgears still jumps to 99%.

    I'd post my Xorg.0.log, but it's far too long for what posting to this forum will allow. If necessary, I'm sure I can post it, somewhere. :/

    Any thoughts??

    Thanks,

    - skubik

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Use pastebin for your log, and just post the link here. Inline pasting is a real pain to read anyways.

    The results with 2.6.28 do seem pretty different to me, in the sense that 3D isn't hanging now... don't forget glxgears does so little actual 3D that it doesn't really count as a 3D test, 99% of the time is spent doing non-3D stuff so glxgears tends to run CPU limited not GPU limited. Can you run a real 3D app (a native Linux game or something) and see what happens ?

    AFAIK either Translucency or Blur have a problem on fglrx, not sure if the problem is in the plug-in or the driver. If things like wobbly windows work then composite is working.

  6. #6
    Join Date
    Jun 2009
    Location
    Calgary, Canada
    Posts
    5

    Default

    Here is the Xorg log: http://pastebin.com/m12a0dfa8

    I was surprised to see composite no longer work since I was at least able to have it to *something* with the previous kernel. At one point I did have wobbly windows and translucency working- but it was unstable & 3D hung the system.

    Will Google Earth be good for testing 3D? I don't have a lot of 3D anything installed at this point beyond that. I can if necessary- but my assumption was, if Google Earth struggles, then why waste my time installing anything else? :/

    Thx,

    - skubik

  7. #7
    Join Date
    Jun 2009
    Location
    Calgary, Canada
    Posts
    5

    Default

    bump. any thoughts??

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •