Results 1 to 6 of 6

Thread: ATI 4830 Low FPS and Garbbled in Jaunty

  1. #1
    Join Date
    Jul 2009
    Posts
    4

    Default ATI 4830 Low FPS and Garbbled in Jaunty

    Hi, I put into this problem many many hours, and I got to the point where I am considering buying an Nvidia card.

    I have 3 Problems:
    1. the right lower corner has a strange pixelation
    2. I get a vary low FPS 72-78
    3. When I work I dual mode where my monitor and TV have different resolutions I am either I a mode where only one of them is working at a time or the small screen doesn't scale the image and it tries to condense the bigger resolution.

    My setup is this:
    Jaunty - fully updated
    Ati installation propriety drivers, I followed the guide at ati.cchtml
    catalyst 9.6
    screen 1 1280x1024
    tv 1280x720

    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 4800 Series
    OpenGL version string: 2.1.8673

    glxgears
    Running synchronized to the vertical refresh. The framerate should be
    approximately 1/86470 the monitor refresh rate.
    379 frames in 5.0 seconds = 75.624 FPS
    376 frames in 5.0 seconds = 75.080 FPS
    376 frames in 5.0 seconds = 75.080 FPS

    Xorg file:
    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    Option "UseFastTLS" "1"
    BusID "PCI:4:0:0"
    Option "VideoOverlay" "off"
    Option "OpenGLOverlay" "off"
    Option "TexturedVideo" "on"
    Option "XAANoOffscreenPixmaps" "true"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection


    Thanks

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    Quote Originally Posted by muni View Post
    glxgears
    Running synchronized to the vertical refresh. The framerate should be
    approximately 1/86470 the monitor refresh rate.
    379 frames in 5.0 seconds = 75.624 FPS
    376 frames in 5.0 seconds = 75.080 FPS
    376 frames in 5.0 seconds = 75.080 FPS
    re: frame rate, you probably have sync-to-vblank enabled (which is fine) so glxgears is running at the same speed as your monitor refresh. If it's really important that glxgears run fast then turn off OpenGL sync-to-vblank in the control panel.

  3. #3
    Join Date
    Jul 2009
    Posts
    4

    Default

    Thanks for your quick reply, does this effect 2d performance.
    where would I disable it? what are the disadvantages or advantages for this setting?
    BTW, I have the feeling that fonts don't look right. they are not sharp enough and there seems to be like slight colourful glow although the fonts are white.

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    No, it will only affect applications using the OpenGL (3D) API. In general you would only disable it if the app you were running had problems with it (eg some apps will end up running at 1/2 or 1/3 of the frame rate under certain conditions.).

    It's hard to comment on font appearance without sitting in front of your computer. If the display resolution is being scaled, either by the GPU or the display electronics, then you might get artifacts from that.

    The pixellation in the lower right corner might be the "unsupported hardware watermark" if your card has PnP IDs which have not been communicated to the driver devs.

  5. #5
    Join Date
    Jul 2009
    Posts
    4

    Default

    thanks, I appropriated the time took to answer.

  6. #6
    Join Date
    Jul 2009
    Posts
    4

    Default

    I still cant get rid of this annoying pixels at the bottom lower corner of the screen, any one?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •