Page 32 of 41 FirstFirst ... 223031323334 ... LastLast
Results 311 to 320 of 406

Thread: ATI R600/700 OSS 3D Driver Reaches Gears Milestone

  1. #311
    Join Date
    Apr 2008
    Location
    A Coruņa (Spain)
    Posts
    100

    Default

    Quote Originally Posted by pingufunkybeat View Post
    Great work, this is an exciting time! My first game of Quake3 on free drivers!
    Which version of quake3 have you tried? In my case, 1.32c (binary) restarts X randomly when approaching a portal (and alsa doesn't work), otherwise it works great. With 1.34-rc3 (compiled) I get alsa sound, but it is unplayable (triangles everywhere!).

  2. #312
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    I have only tried OpenArena, which is ioquake3.

    A workaround for the triangle mess is to start the game with "LIBGL_ALWAYS_INDIRECT=1 openarena". It reportedly also fixes other games, like vdrift.

    Unfortunately, it crashes from time to time when using LIBGL_ALWAYS_INDIRECT. It didn't use to crash in the direct mode (but then it's unplayable).

  3. #313
    Join Date
    Apr 2008
    Location
    A Coruņa (Spain)
    Posts
    100

    Default

    Quote Originally Posted by pingufunkybeat View Post
    A workaround for the triangle mess is to start the game with "LIBGL_ALWAYS_INDIRECT=1 openarena". It reportedly also fixes other games, like vdrift.
    Yeah, thanks, that was it. Quake3 1.34-rc3 works great now (leaving aside the random X restarts, of course ).

  4. #314
    Join Date
    Nov 2008
    Posts
    30

    Default

    So these drivers can do OpenArena now? Nifty...

    A few questions:
    How stable are they? (If unstable when do they crash, what are you doing when it occurs?)
    What is performance like compared to catalyst?

    Thanks for your time.

  5. #315
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    For me, they are surprisingly stable. This is all still preliminary, experimental, and unreleased stuff, but it rarely crashes for me.

    2D is rock solid. 3D hangs on a couple of things for me (KWin with OpenGL effects and foobillard), and a couple of things don't work (supertuxkart). But the things that work, work with no problems.

    The major remaining bug is the graphical corruption in games like OpenArena. When using direct rendering, it is unplayable, along with some other geometrically more complex games. Still, it doesn't crash, at least for me.

    The workaround is to run these games indirectly. Then they render perfectly, but do crash the X server from time to time. OpenArena crashes (kills X, basically) every time you win a level, for example. It works fine until then.

    So I guess that there are two major bugs here, the corruption in the direct rendering mode, and the X crashes in the indirect mode. When they are finished, these things will be usable for daily work, and it will be bug-hunting time. The devs have been hunting the corruption one for the last few days, and there are first commits which considerably improve things. I think the bug is slightly better understood now, and with some luck, the devs will figure out how to fix it soon.

    I don't know about the comparison to catalyst, as I've never run it. I imagine it's definitely inferior at this time, and it doesn't offer all the features (OpenGL 2+ is only coming with the KMS/GEM/DRI2/Gallium stack, for example).

    EDIT: This is my understanding of the situation as an interested observer who runs the latest drivers from git and reads the IRC channel. I'm sure that the devs will be able to explain things in more detail.
    Last edited by pingufunkybeat; 08-20-2009 at 05:45 PM.

  6. #316
    Join Date
    Dec 2008
    Posts
    995

    Default

    For me I haven't had the time to really test OpenGL games, but I have been running Compiz over a week now with this driver and it works great and unlike fglrx no crashes at all.

    Now all AMD has to do is make hardware accelerated H.264 decoding available and I'm a satisfied customer

  7. #317
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    640

    Default

    but I have been running Compiz over a week now with this driver and it works great and unlike fglrx no crashes at all


    no graphical corruption or corruption during text input for you ?

    if that's the case - I'm impressed !

    I asap need to re-install all of those related ebuilds

    thanks devs !

  8. #318
    Join Date
    Dec 2008
    Posts
    995

    Default

    Quote Originally Posted by kernelOfTruth View Post


    no graphical corruption or corruption during text input for you ?
    Sometimes a little text corruption during text input in gnome-terminal (but not in Vim though), that's all, just a minor annoyance I can live with till it's resolved.

  9. #319
    Join Date
    Jul 2009
    Posts
    416

    Default

    Quote Originally Posted by pingufunkybeat View Post
    run it with LIBGL_ALWAYS_INDIRECT=1
    How do you do that?

  10. #320
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by pvtcupcakes View Post
    How do you do that?
    In a terminal do

    LIBGL_ALWAYS_INDIRECT=1 openarena

    and hope it runs for you (doesn't seem to work for everyone - game refuses to start)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •