Results 1 to 3 of 3

Thread: S3 linux driver, dated 06/26/2009. Supports vdpau?!?

  1. #1
    Join Date
    Apr 2007
    Location
    Arctic circle, Finland
    Posts
    260

    Default S3 linux driver, dated 06/26/2009. Supports vdpau?!?

    Err higlights:
    06/26/2009: Version 14.02.17
    - Bug Fixes
    - XRandR support
    - VDPAU support
    - KMS Support

    Well are there anyone who has these kind of graphics cards, just curious... I really hope that Michael get one of these somewhere. If these truly support both vaapi and vdpau now, video acceleration test againts nvidias products will be very interesting read.

    release notes:
    http://drivers.s3graphics.com/en/dow...N_Linux_EN.txt
    Download:
    http://www.s3graphics.com/en/drivers...spx?seriesId=4

  2. #2
    Join Date
    Jan 2009
    Posts
    206

    Default

    ZOMG!
    This puts ATI into shame!

    It almost looks like VIA has been working with Nvidia, the packages seems to include precompiled libGL.so and VDPAU library / header. Hmm I wonder how did they get KMS working, It seems some drm code is in 's3gdrm'. Holy grail has been found for VIA users.

  3. #3
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,733

    Default

    Note, while Via owns S3, both make independent graphics cards; Via tends to concentrate on the integrated stuff, while S3 makes both. The drivers for either don't work with the other.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •