Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Radeon HD 4650 AGP

  1. #11
    Join Date
    Aug 2009
    Posts
    16

    Default

    Thanks Kano, that script is for Kantonix & I'm using Debian, although I think it is based on Debian. When I do try to run it anyway it gives errors about not being Kantonix & that the script must be run outwith X! Is there a Debian version available?

    Is the script purely for better fglrx installation so that it doesn't break with other system updates, or are there other improvements that would solve the video playback problem I described? You can tell I'm not a power-user/programmer!

  2. #12
    Join Date
    Aug 2007
    Posts
    6,633

    Default

    As long as your Xserver is not too new, like Debian squeeze is too new it does not break anything. It needs a correct (or missing) xorg.conf file, so

    rm -f /etc/X11/xorg.conf
    dpkg-reconfigure -phigh xserver-xorg

    will be ok. Debian lenny writes for example keyboard settings in there. For newer distros this file just does not exist.

  3. #13
    Join Date
    Apr 2007
    Posts
    99

    Default

    I also have the Radeon HD 4650 AGP 1GB card and it works as well as it could using FGLRX. The only problem I'm having is the same with the open source radeon and radeonhd drivers. Using the latest radeon git was the only way I was able to get my desktop running on open source drivers and anything 3D besides Kwin desktop effects will crash X.

    FGLRX works on my end perfectly. It may be the hardware (Shuttle nForce 2) or the software mix, who knows.

    It's running Debian Sid (Xserver and Xorg packages are on hold for 1.6.5) + the Liquorix kernels (2.6.32.7).

    The Liquorix kernels have MTRR cleanup support enabled + x86 PAT support - this may explain why I'm having more success than the rest of you

  4. #14
    Join Date
    Apr 2007
    Posts
    99

    Default

    Hmm, editing posts was disabled for dumb reason. But here's the output of inxi for anyone interested.

    Code:
    $ inxi -F
    System:    Host damentz-box Kernel 2.6.32-7.dmz.1-liquorix-686 i686 (32 bit) Distro sidux 2009-02 Αιθήρ - kde-lite - (200907141544)
    CPU:       Single core AMD Athlon XP 3200+ (UP) cache 512 KB flags (sse) bmips 4411.82 clocked at 2205.059 MHz
    Graphics:  Card ATI RV730 Pro AGP [Radeon HD 4600 Series] X.Org 1.6.5 Res: 1024x768@60.0hz
               GLX Renderer ATI Radeon HD 4600 Series    GLX Version 3.2.9252 Compatibility Profile Context Direct Rendering Yes
    Audio:     Card-1 ATI RV710/730 driver HDA Intel
               Card-2 Creative Labs SB Audigydriver EMU10K1_Audigy at port c000
               Sound: Advanced Linux Sound Architecture Version 1.0.21
    Network:   Card-1 Broadcom BCM4306 802.11b/g Wireless LAN Controller driver b43-pci-bridge
               Card-2 nVidia nForce2 Ethernet Controller driver forcedeth at port ec00
    Disks:     HDD Total Size: 500.1GB (3.3% used) 1: /dev/sda  500.1GB
    Partition: ID:/ size: 12G used: 4.1G (39%) fs: ext4 ID:/boot size: 122M used: 17M (15%) fs: ext2
               ID:/home size: 447G used: 12G (3%) fs: ext4 ID:swap-1 size: 1.02GB used: 0.00GB (0%) fs: swap
    Sensors:   System Temperatures: cpu: 38.0C mobo: N/A gpu: 37.50C
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes 107 Uptime 5:23 Memory 250.0/2026.1MB Runlevel 5 Client Shell inxi 1.3.4
    Wow, the GPU idles at 37.5*C, nice going ATi!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •