Hi,
I used catalyst 9.1 / 9.2 / 9.3 with arch linux using 2.6.28.5 vanilla kernel with xserver 1.5 for few months.
Today I've upgraded the system (350 new packages), I've downgraded as always xserver to 1.5 (this is not the first time I did it),
at first I get some cold reboots or kernel panics with 9.3 and component output. Then I installed 9.2 and swithced to s-video and now X doesn't start anymore..
this is my log: http://dl.getdropbox.com/u/158338/li...o09/Xorg.0.log

and this is the xorg.conf: http://dl.getdropbox.com/u/158338/li...go09/xorg.conf

the errors are:

Code:
(EE) fglrx(0): [FB] Can not get FB MC address range.
(EE) fglrx(0): Unknown EDID version 0
(EE) fglrx(0): Output TV enabled but has no modes
(EE) fglrx(0): Display Infrastructure Failed
(EE) fglrx(0): PreInit failed
(EE) Screen(s) found, but none have a usable configuration.
I've downgraded the following packages:

Code:
mesa-7.2-1-i686.pkg.tar.gz
xf86-input-evdev-2.1.2-1-i686.pkg.tar.gz
xf86-input-keyboard-1.3.1-1-i686.pkg.tar.gz
xf86-input-mouse-1.3.0-1-i686.pkg.tar.gz
xorg-server-1.5.3-4-i686.pkg.tar.gz
xorg-server-utils-7.4-2-i686.pkg.tar.gz
xorg-util-macros-1.2.1-1-i686.pkg.tar.gz
tell me if there are some more packages that I could downgrade....

thanks.