Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: HDMI audio support for RV730 in radeon/radeonhd?

  1. #11
    Join Date
    Oct 2007
    Posts
    1,268

  2. #12
    Join Date
    Jul 2008
    Posts
    208

    Default

    Quote Originally Posted by AndyW View Post
    As I said, HDMI audio works with onboard disabled under Windows or with fglrx. I could probably take an output from the on board sound card to the TV, but there might be synchronisation problems, and in any case that defeats the aim of having sound through HDMI. This is the aplay -l output with onboard audio enabled:-
    Code:
    [root@localhost ~]# aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC885 Analog [ALC885 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC885 Digital [ALC885 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    Your aplay -l matches mine. I would have thought that with additional video card you would have some additional hdmi output.

    Good that sound works over hdmi with onboard sound card disabled in bios? If you have no other sound card, then the bios disable must just turn off ports and the onboard sound chip must still be working? If you have no direct cable from sound card/chip to to non-integrated video then the data must be on the pci-express bus. I had not heard that working but also never reviewed it. The problems that other people post regarding various video card sound hdmi problems often discuss a direct connection (sound chip to non-integrated video).

    So if those bugs are resolved for radeonhd you should be good to go with the opensource drivers. Good luck.

  3. #13
    Join Date
    Aug 2009
    Location
    UK
    Posts
    18

    Default

    Disabling the onboard audio in BIOS doesn't just disable the ports, it completely removes (logically) the device. lspci shows an additional device when I run it with audio enabled. It is the equivalent of physically removing an expansion card.

    The HDMI audio is an alternative to onboard, at least for sound output. There are advantages to having onboard sound as well, such as audio capture. However for HTPC the integrated HDMI audio is the best output option. If you need surround sound (I don't), headphones etc. you take those from the HDMI output device - either an audio receiver with video passed through to TV, or the TV directly. Taking audio (either analog or digital) from the sound card to the TV is very much second best if HDMI audio is available & working.

    From some of the mailing list posts it looks like there are problems getting HDMI audio to work with add-on cards. I think developers have focussed on the GPU embedded in the ATI chipsets - which does make sense as it is a more static target and benefits more users. Looks like there is a bug in radeonhd with R730, as the audio device is visible and i don't actually get errors - just lack of sound.

  4. #14
    Join Date
    Aug 2009
    Location
    UK
    Posts
    18

    Default

    I have built radeonhd 1.3 from the git code released last week. Makes no difference to HDMI audio, but I now have the rhd_dump utility (not included in Fedora compiled package).

    I dumped registers from 7000 to 7900 while running radeonhd and again after installing fglrx. I diffed the output and used it to make a script to apply the fglrx register values one at a time while running radeonhd.

    It looks like 0x75A0 turns on HDMI audio, along with other things besides. If I change it from 0x00000311 (radeonhd value) to 0x10000310 (fglrx value) the sound comes on - but also changes my resolution from 1920x1080 to what looks like 1024x768, even though xrandr still says it is in 1920x1080 mode. I can't find any way to change it back, though apart from that everything (audio and video) is fine.

    Maybe if any of the radeonhd developers see this they can advise on fine-tuning the register settings? I saw a posting on the mailing list where the same register (0x75A0) controlled HDMI audio on a different RV7xx chipset, though with different values http://lists.opensuse.org/radeonhd/2.../msg00012.html. In any case hopefully this will be of use for development. If I can find the right value to switch on HDMI audio without messing the resolution and can set it from e.g. a login script I shall be very happy! :-)

    I have also seen on the mailing list and here that HDMI audio has been ported to the KMS driver due for release with 2.6.32. Does HDMI audio work for RV730 on KMS (i.e. audio problem is to do with KMS vs. non-KMS) or is it a straight port with no difference in outcome?

    BTW with fglrx the system completely freezes (at any rate X does) somewhere between immediately and a few minutes after logging in. I followed the procedure on Fedora Forums - I had to follow the initrd steps otherwise the display is corrupted, but I didn't regenerate xorg.conf from scratch, so there may be incompatible settings for DRI etc. Much better to use OSS!
    Last edited by AndyW; 10-14-2009 at 04:52 AM.

  5. #15
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,434

    Default

    I think it's a straight port. We need to dig up some more info on the audio gating hardware and get that info into code or docs.

    I haven't heard of anyone successfully enabling audio over HDMI on a 730 with open source drivers yet.

  6. #16
    Join Date
    Oct 2009
    Location
    Brisbane, Queensland, Australia
    Posts
    154

    Default

    Quote Originally Posted by AndyW View Post
    It would help if the Xorg wiki had feature tables in order to make it easier to determine whether something like this is meant to be working, has a known bug or has not been implemented yet.
    The best I could find was http://wiki.x.org/wiki/RadeonFeature
    Unfortunately it doesn't break things down to the individual chip types. The changelog at http://wiki.x.org/wiki/radeonhd doesn't help much either, it just says "Added support for HDMI audio on RS690 and R700."

    So I guess bridgman's comment above is the best inidcator we can get at the moment.

  7. #17
    Join Date
    Oct 2009
    Location
    Brisbane, Queensland, Australia
    Posts
    154

    Default

    You could also try asking one or more of the people listed in the code commit titled "R700 HDMI audio support" at http://cgit.freedesktop.org/xorg/dri...a742818e18df72

  8. #18
    Join Date
    Dec 2007
    Posts
    2,360

    Default

    I've got a set of patches on top of Christian's to clean up and document the registers and bits. Might also fix rv730, but I don't have an hdmi sink to test with at the moment. As soon as the patches are approved, I'll post them to the ML.

  9. #19
    Join Date
    Aug 2009
    Location
    UK
    Posts
    18

    Default

    Sounds good - I am up for HDMI testing on RV730 (or any other testing for that matter, though my main focus is on 2D and audio as this is an HTPC project). Will the patches be for radeonhd or for the drm-next KMS driver?

    Madbiologist: Thanks for the link. I take back what I said about the feature table, though you are right it would help to break out into individual chipsets, given the differences within even the same family. The wiki is difficult to navigate - it is hard to find something unless you know pretty much exactly what it is to start with.

  10. #20
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,434

    Default

    AFAIK the issue with audio on 730 (probably 710 as well) is the only chip-specific one we have; probably not worth reformatting the entire table to deal with it.

    There are chip-specific bugs from time to time, which probably wouldn't make it into the table anyways; might make more sense to treat the 730 audio support as a bug rather than a missing feature.

    Personally I would rather see a relatively small table that is accurate and up to date than a hugely detailed table which has not been correct since 1999

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •