Page 1 of 25 12311 ... LastLast
Results 1 to 10 of 243

Thread: AMD Catalyst 9.8 Delivers New Kernel Support

  1. #1
    Join Date
    Jan 2007
    Posts
    14,359

    Default AMD Catalyst 9.8 Delivers New Kernel Support

    Phoronix: AMD Catalyst 9.8 Delivers New Kernel Support

    It's taken quite a while, but AMD has finally delivered support for the Linux 2.6.29 kernel within their Catalyst driver. The Linux 2.6.29 kernel was released in March, but it has taken until today for AMD to release any support for this kernel...

    http://www.phoronix.com/vr.php?view=NzQ2Mw

  2. #2
    Join Date
    May 2009
    Posts
    80

    Default

    Great! Finally I can switch to F11 repos and do yum upgrade

  3. #3
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,778

    Default

    Seems to work OK in Gentoo with kernel 2.6.30-r5. Resizing/maximizing problem still there. The mplayer (gl backend) GUI corruption in KDE4 with desktop effects enabled problems seem to have been fixed though; haven't seen any menus and buttons in SMPlayer going missing/replaced with garbage yet.

  4. #4
    Join Date
    Jan 2009
    Posts
    18

    Default

    No change with Xv+Composite, but one thing is cool. I ran Street Fighter 4 benchmark with wine 1.1.26. Before my computer froze when I changed the resolution of the test, now it is ok. Still not playable (image is flickering) but it is a good step forward.

  5. #5
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,117

    Default

    Quote Originally Posted by rafi View Post
    No change with Xv+Composite, but one thing is cool. I ran Street Fighter 4 benchmark with wine 1.1.26. Before my computer froze when I changed the resolution of the test, now it is ok. Still not playable (image is flickering) but it is a good step forward.
    What problems do you experience with Xv+Composite?

  6. #6
    Join Date
    Jan 2009
    Posts
    18

    Default

    Well, like with the 9.7, the image get blurred when the window of the video player is on the left of the screen and the video is black after minimizing the video player (vlc and smplayer tested). To get the image back I just have to resize the window, so there is no real problem with Xv+composite, I just wanted to say that it didn't get better. Anyway the little improvement in wine is cool.

  7. #7
    Join Date
    Aug 2008
    Posts
    56

    Default

    Ho-hum. No XvBA support. So glad I switched to Nvidia for my HTPC. My 780g board is now relegated to the living room web browser 'net top'. Glad to see AMD making progress, but the lack of accelerated video support on par with VDPAU is really just sad at this point. Just sad. I'll say it again. Sad.

  8. #8
    Join Date
    Jun 2008
    Posts
    197

    Default

    91.7mb? Don't you just love to hate AMD/ATi

  9. #9
    Join Date
    Aug 2008
    Posts
    57

    Default Yeeeeey!...NOT.

    Quote Originally Posted by phoronix View Post
    Phoronix: AMD Catalyst 9.8 Delivers New Kernel Support

    It's taken quite a while, but AMD has finally delivered support for the Linux 2.6.29 kernel within their Catalyst driver. The Linux 2.6.29 kernel was released in March, but it has taken until today for AMD to release any support for this kernel...

    http://www.phoronix.com/vr.php?view=NzQ2Mw
    After a couple of minor adjustments to my system to ditch the default Fedora setup for radeon (blacklist, mkinitrd, etc.) I managed to install the driver and it worked for almost A WHOLE MINUTE before hanging the system. NICE. FANTASTIC. AWESOME.

    Great work guys, thanks!

  10. #10
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    197

    Default

    Okay, I've done fast tests comparing 9.7 and 9.8, here are the results :
    Code:
    glxgears :
    -------
    fglrx 9.7 :
    53380 frames in 5.0 seconds = 10675.902 FPS
    52212 frames in 5.0 seconds = 10442.344 FPS
    54455 frames in 5.0 seconds = 10890.948 FPS
    54634 frames in 5.0 seconds = 10926.746 FPS
    54642 frames in 5.0 seconds = 10928.370 FPS
    
    fglrx 9.8 :
    53251 frames in 5.0 seconds = 10650.068 FPS
    53398 frames in 5.0 seconds = 10679.592 FPS
    53512 frames in 5.0 seconds = 10702.357 FPS
    53515 frames in 5.0 seconds = 10702.912 FPS
    52923 frames in 5.0 seconds = 10584.525 FPS
    -------
    
    fgl_glxgears :
    -------
    fglrx 9.7 :
    16354 frames in 5.0 seconds = 3270.800 FPS
    14017 frames in 5.0 seconds = 2803.400 FPS
    16523 frames in 5.0 seconds = 3304.600 FPS
    14438 frames in 5.0 seconds = 2887.600 FPS
    15332 frames in 5.0 seconds = 3066.400 FPS
    
    fglrx 9.8 :
    16568 frames in 5.0 seconds = 3313.600 FPS
    16774 frames in 5.0 seconds = 3354.800 FPS
    16844 frames in 5.0 seconds = 3368.800 FPS
    15977 frames in 5.0 seconds = 3195.400 FPS
    16838 frames in 5.0 seconds = 3367.600 FPS
    -------
    
    q3a :
    -------
    fglrx 9.7 :
    840.0 fps
    772.1 fps
    833.3 fps
    807.3 fps
    802.5 fps
    
    fglrx 9.8 :
    660.1 fps
    751.4 fps
    825.7 fps
    705.5 fps
    537.5 fps
    -------
    
    hon :
    -------
    fglrx 9.7 :
    ~60 in game
    
    fglrx 9.8 :
    ~80 in game :
    -------
    
    tropics 1.2 aax2 :
    -------
    fglrx 9.7 :
    30.8 fps
    776 score
    
    fglrx 9.8 :
    38.0 fps
    957 score
    -------
    Okay, but don't get your hopes too high :/ although tropics improved quite a lot, but that because I've got errors in rendering :/ whole benchmark was missing water and screen was flickering before I've turned aa on so something is wrong with this drivers.

    As for hon, well i've measured it durning a game play, so it's not really reliable because I wasn't watching the fps all the time, but I think there is a little improvement.

    My system and rig :
    ubuntu 9.04 amd64
    E6550@3.15GHz
    HD4850@stock
    4GB DDR2-900

    Can anyone test unigine tropics ? I'll try sanctuary now.

    EDIT :
    okay, I've tested few things with tropics and found out that first run gives me like 0-4fps and screen corruption (blue and black lanes). But when I change to aax2, everything is looking fine, only water is missing... BUT... when I turn on aax4 or more everything is fine ;o no screen flickering, no corruption, water is perfect... ;x it has to be driver thing :x
    Last edited by Tares; 08-17-2009 at 05:51 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •