Page 5 of 5 FirstFirst ... 345
Results 41 to 45 of 45

Thread: Looking for help testing my game

  1. #41
    Join Date
    Jul 2009
    Posts
    72

    Default

    I would comment about mac support but the wiki is locked. What is your build method/environment?

  2. #42
    Join Date
    Aug 2009
    Posts
    16

    Default

    Quote Originally Posted by whizse View Post
    The bug in Mesa has been fixed.

    I can start the game now, but it doesn't render correctly in-game, and performance is pretty much nil. Guess there's still one or two bugs to be filed against Mesa.
    Glad to hear that the shader bug is fixed. I'm not surprised that there are problems with performance in Mesa, unfortunately. It was barely playable on my old X300 with fglrx, so it doesn't scale down all that all (although in my defense the X300 is a pretty old card these days).

    Quote Originally Posted by dacresbu View Post
    I would comment about mac support but the wiki is locked. What is your build method/environment?
    You will need to have a SourceForge account to edit the wiki.

    The build on Linux is just a custom makefile with dependencies handled by makedepend. It's not perfect, but it works. The Windows build is just a Visual Studio project with all of the source files added, so I would expect any other IDE to be pretty easy to setup too.

    Full details on building on Linux and Windows can be found on the source code page of the wiki.
    Last edited by cybertron; 09-16-2009 at 04:31 PM.

  3. #43
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    It seems the bug is specific to Intel cards. The software rasterizer render the game fine. Filed a new bug about that:
    https://bugs.freedesktop.org/show_bug.cgi?id=23978

  4. #44
    Join Date
    Jul 2009
    Posts
    72

    Default more like to view it

    You will need to have a SourceForge account to view edit the wiki.
    there fixed that for ya. I really don't want to have to maintain a Sourceforge account just to look at a wiki. (its like maintaining a windows distro just to play games)


    The build on Linux is just a custom makefile with dependencies handled by makedepend.
    seems duplicable on the mac. I'll see if I can't provide a universal binary. you aren't directly addressing X are you?

  5. #45
    Join Date
    Aug 2009
    Posts
    16

    Default

    Quote Originally Posted by dacresbu View Post
    there fixed that for ya. I really don't want to have to maintain a Sourceforge account just to look at a wiki. (its like maintaining a windows distro just to play games)
    Hmm, it shouldn't be that way, although now that you mention it I always wondered about the fact that it always prompts for a password. There must be something weird about the way SF has it setup because the Trac settings should allow anyone to view.

    Ah, found it. If you use the HTTPS link it will always ask for authentication. I need to change my links to regular HTTP.

    seems duplicable on the mac. I'll see if I can't provide a universal binary. you aren't directly addressing X are you?
    Good heavens, no!

    About the only thing I've really had problems with as far as cross-platform goes is that the Visual C++ STL still sucks performance-wise, so I use STLPort on Windows which has caused other problems. Since I think you'll be using some variant of gcc you shouldn't have that problem. I use quite a few libraries, but they should all be available on Mac too. They're listed here (this link should work).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •