Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Keep aspect ratio on LCD Panel

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default Keep aspect ratio on LCD Panel

    I just got a Gateway MD2614u with HD3200 graphics and a 1366x768 screen. Some games, like ioquake, don't let me select the native resolution, so selecting 1024x768 results in a stretched screen. Is there a way to disable video resulution scaling, or to keep the resolution aspect ratio?

    I'm using Catalyst 9.8 with Kubuntu 9.04 and kernel 2.6.30.5.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,766

    Default

    If you have a digital monitor, then there are controls for that in catalyst control center (select "keep aspect ratio").

    It doesn't work with analog monitors though.

  3. #3
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Quote Originally Posted by RealNC View Post
    If you have a digital monitor, then there are controls for that in catalyst control center (select "keep aspect ratio").

    It doesn't work with analog monitors though.
    The display is the laptop's built-in screen, so it is digital. The option is present in the Windows drivers, but not in Linux.

    I'll try your suggestion Fran, but I still want to disable the display stretch.

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,766

    Default

    Quote Originally Posted by glock24 View Post
    The display is the laptop's built-in screen, so it is digital. The option is present in the Windows drivers, but not in Linux.
    I wouldn't mention it if the option wasn't there for Linux too.


  5. #5
    Join Date
    Nov 2008
    Location
    Managua, Nicaragua
    Posts
    83

    Default

    Well, I just checked on my other laptop, which has a HD3650, and the display scaling options are also missing. Here's a screenshot:



    This option was available in Catalyst 9.5 or 9.6 if I remember correctly, maybe this is a bug in 9.8? Is there any xorg.conf options I should enable?

  6. #6
    Join Date
    Apr 2008
    Location
    A Coruņa (Spain)
    Posts
    100

    Default

    Quote Originally Posted by glock24 View Post
    I just got a Gateway MD2614u with HD3200 graphics and a 1366x768 screen. Some games, like ioquake, don't let me select the native resolution, so selecting 1024x768 results in a stretched screen. Is there a way to disable video resulution scaling, or to keep the resolution aspect ratio?
    I know this is not the answer for your question, but if ioquake configuration is like quake3's (and I suppose it is), you can set your desired resolution with
    Code:
    seta r_customheight "1050" <-- your y
    seta r_customwidth "1680" <-- your x
    seta r_mode "-1"
    in the config file.

  7. #7
    Join Date
    Mar 2009
    Posts
    176

    Default

    Yep they're missing, I noticed that right away, but ignored it since I decided that I preferred centered mode with the black borders anyways...
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  8. #8
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    You need to connect the monitor with DVI/HDMI not via analog vga to get those options.

  9. #9
    Join Date
    Mar 2009
    Posts
    176

    Default

    Quote Originally Posted by Kano View Post
    You need to connect the monitor with DVI/HDMI not via analog vga to get those options.
    Mine is a notebook, and those options appear under the windows drivers which is where I made the determination that I preferred centered anyways...
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  10. #10
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,766

    Default

    aticonfig --help lists an option:

    --lcd, --lcd-mode=STRING
    Change the LCD mode. STRING can be one of:
    center
    full

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •