Results 1 to 6 of 6

Thread: HD4890 Ati-driver 9.8: no mouse in openGL ann more

Hybrid View

  1. #1
    Join Date
    Aug 2009
    Posts
    11

    Default HD4890 Ati-driver 9.8: no mouse in openGL ann more

    Hello

    I've figured out how to install ATI's Catalyst 9.8 drivers with Debian Squeeze (testing) 2.6.30-1-amd64 #1 SMP. This was the thread the helped a lot with solving the installation problems:

    http://www.phoronix.com/forums/showthread.php?t=18681

    However, there are still some major issues:

    1) There is no way I can see the mouse pointer in full screen OpenGL applications. Both under wine or native. I've tried putting
    Code:
    Option "SWCursor" "false"
    ,
    Code:
    Option "SWCursor" "true"
    and no mouse option. Either way the mouse just disappears.

    2) It is almost impossible to open menu items when SMPlayer (MPlayer) is playing a movie in a window. Everything slows to a crawl. In order to be able to watch movies in full screen mode I've had to configure the player to use OpenGL.

    3) Flash movies (for example, Youtube) are very, very slow. Fullscreen viewing is also impossible. I've googled a lot and tried to enable or disable HW acceleration, but there was no change. This happens with Adobe's Flash 10 under Iceweasel (Firefox) and Konqueror.

    4) Compiz, while integrated into KDE4, is just useless. You can't select any kind of text, the mouse draws random squares on the screen and OpenGL apps just freeze the system or refuse t work. It must be turned off in order to provide a usable desktop.

    5) The overall graphics experience is disappointing, to be polite. My older system had an old Atlhon XP 2000 processor with an old Nvidia 5200FX GPU. It felt more stable and a lot faster in 2D and 3D. My current system is an Intel i7 with ATI's HD 4890, lots of disk and RAM. I would expect the overall experience to be a little better than the old one.

    I've bought an AMD/ATI card because of their willingness to help with open source drivers. However, I didn't have a clue about how crude and lacking their proprietary drivers were.

    I still believe my choice was kind of correct and that there will be quality open source drivers sometime in the future, but I'm stuck with the current drivers for a while. Is there anything you guys know that can help to improve anything?

    Thanks,
    Soeiro
    Last edited by soeiro; 09-04-2009 at 07:01 PM. Reason: typos

  2. #2
    Join Date
    Aug 2009
    Posts
    11

    Default Any hints, anyone?

    I've just installed fglrx version 10-4-1 and (xorg 7.5+6
    ) from the debian squeeze repositories and the situation is the same: I can't see the mouse pointer when in fullscreen mode.

    Either in half-life 2 (Wine) or in Tropical demo (native).

    At first I thought it was a wine problem, but since the demo doesn't work either, it must be something else.

    1) Is there anyone with a similar problem?

    2) Does anybody use Debian/squeeze with the HD 4890 GPU? If so, what special configuration have you done?

    3) Any other Debian/squeeze user with fglrx driver working?

    Thanks,

    Luis

  3. #3
    Join Date
    Nov 2008
    Posts
    787

    Default

    I doubt it'll help you, but I'm using fglrx on a 5770 (gentoo) and my mouse cursor works fine in all kinds of fullscreen apps.

    About general 2d performance, did you apply the backclear patches to xorg? I'm not sure if debian does so by default.

    Fullscreen flash is slow on almost anything. It's slow on my HD 5770, it's slow on my nVidia NVS 140M, it was slow on my GeForce 7600 GT. The common element here is "adobe flash", which is a pile of garbage anyway.
    I've used youtube-dl + mplayer for a while, hopefully VP8 will change things.


    For the record, the only gripes I have with fglrx is wine trouble. Everything else I use works just as good or better than it did with nvidia. But I have no idea why it doesn't for you, sorry.

  4. #4
    Join Date
    Aug 2009
    Posts
    11

    Default

    Quote Originally Posted by rohcQaH View Post
    About general 2d performance, did you apply the backclear patches to xorg? I'm not sure if debian does so by default.
    I didn't try to apply them... I was wondering if it is possible to have a working system first, and the then get optimizations. Right now, the most annoying thing is the missing mouse pointer.

    Quote Originally Posted by rohcQaH View Post
    Fullscreen flash is slow on almost anything. The common element here is "adobe flash", which is a pile of garbage anyway.

    I've used youtube-dl + mplayer for a while, hopefully VP8 will change things.
    Agree. I've even thought my wife how to look for the flash temp file and open it with SMPlayer or VLC in order to watch it fullscreen. ;-)

    Quote Originally Posted by rohcQaH View Post
    But I have no idea why it doesn't for you, sorry.
    :-(

    Did you have to do any additional configuration to get things working?

  5. #5
    Join Date
    Nov 2008
    Posts
    787

    Default

    Quote Originally Posted by soeiro View Post
    Did you have to do any additional configuration to get things working?
    no.

    emerge -C nvidia-drivers
    emerge ati-drivers
    vi /etc/X11/xorg.conf, s/nvidia/fglrx, enter the new BusID
    reboot

    and it worked.

    I had to do some additional configuration to replace TwinView with Xinerama for my multiscreen setup, but that shouldn't be the issue here.


    yeah, I know, I'm not helping

  6. #6
    Join Date
    Aug 2009
    Posts
    11

    Default Almost there!

    After the last debian/squeeze update, fullscreen OpenGL applications started to show a mouse pointer!

    The only thing that is bothering me is Half-Life 2 under Wine...It used to work on my old Nvidia FX5200. Now under the HD 4890 it sort of works, but I still get no mouse pointer! :-(

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •