https://lists.ubuntu.com/archives/ka...er/008022.html

Supports Ubuntu 9.10 including Linux 2.6.31. Should be on your mirror soon I guess