Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Performance regressions with C'n'Q, C1E, SB750

  1. #11
    Join Date
    May 2009
    Posts
    22

    Default

    @cruncher:

    The fglrx driver doesn't affect the performance regressions I have noticed.

  2. #12
    Join Date
    Sep 2007
    Location
    Connecticut,USA
    Posts
    941

    Default

    Quote Originally Posted by RealNC View Post
    The kernel configuration docs ("conservative" frequency scaling governor) have this to say about AMD64 CPUs:

    "If you have a desktop machine then you should really be considering the 'ondemand' governor instead, however if you are using a laptop, PDA or even an AMD64 based computer (due to the unacceptable step-by-step latency issues between the minimum and maximum frequency transitions in the CPU) you will probably want to use this governor."
    So you are saying to use OnDemand governor if you are using a desktop, and Conservative for laptops?

    My desktop is an AMD64 X2 and I use the OnDemand governor. My laptop uses an Intel Pentium M...and at the moment its using the OnDemand governor as well. Should the laptop use Conservative or the OnDemand? Right now I am not experiencing any obvious issues on either machine though

  3. #13
    Join Date
    Feb 2009
    Posts
    23

    Default

    If you want to increase the responsiveness of frequency switching check this out.

    cat /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate_min

    Should tell you a value. In my case its 10900.

    echo 10900 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate

    Your System will now respnse faster in regard to frequency switching.

    Note: This may produce an overhead.

  4. #14
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    no need to deactivate anything in the bios (except C1E, this one really, really hurts).

    If you need performance:
    cpufreq-set -g performance
    if you don't need max performance:
    cpufrq-set -g ondemand
    if you want to save power but need the box running:
    cpufreq-set -g powersave

    it is really that simple.

    Oh, with PhenomII you need to do that for all cores:
    cpufreq-set -c3 -g performance
    cpufreq-set -c2 -g performance
    cpufreq-set -c1 -g performance
    cpufreq-set -c0 -g performance

    don't bother with bios.

  5. #15
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    Quote Originally Posted by Max Spain View Post
    That is to be expected. It's the same with Intel. When you enable CnQ or speedstep, it takes *time* to change states. It isn't a lot of time, but that delay will reduce performance. It is for this reason I don't use those features. I set my clocks and voltages manually in the BIOS before booting based on what I am going to use the system for. This way I get the best of both worlds.
    no, that way you get the worst of all worlds.

    Just set the governor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •