Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: r500 and flash = awful

  1. #1
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default r500 and flash = awful

    card:
    ati x1600 pro agp

    kernel:
    Linux 2.6.31-10-386 #30-Ubuntu SMP Tue Sep 8 14:28:09 UTC 2009 i686 GNU/Linux

    glxinfo:
    OpenGL vendor string: DRI R300 Project
    OpenGL renderer string: Mesa DRI R300 (RV530 71C2) 20090101 AGP 4x x86/MMX/SSE2 TCL
    OpenGL version string: 1.5 Mesa 7.7-devel

    xorg log:
    http://pastebin.com/f1f45ca4c

    i'm using this on jaunty https://bugs.launchpad.net/~xorg-edgers/+archive/ppa and i shouldn't have kms enabled (didn't touch anything)

    problem:
    adobe flash performances are just awful, they decreased dramatically since i upgraded to this fresh git stuff, i.e. youtube is almost^W unusable (3ghz p4 cpu), everything else seems fine (didn't try any games or other stuff), with ubuntu jaunty's stock drivers everything (about flash) was better, even if it still sucked a bit though..

    i didn't find a way to contact devs/packagers so i report my bug here


    cheers

    (sorry for bugmenot but i couldn't remember my account and i was in a hurry)
    Last edited by bugmenot; 09-15-2009 at 01:36 PM.

  2. #2
    Join Date
    Dec 2007
    Posts
    2,277

    Default

    Adobe's flash does not use hw acceleration on the open source drivers.

  3. #3
    Join Date
    Jan 2009
    Location
    Italy
    Posts
    82

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,763

    Default

    That's total crap. I can watch 1080p videos on mplayer with the X11 non-accelerated renderer. Flash on Linux is so much crap, it even lags with 480p videos. You don't need any kind of acceleration for this. But Flash is crap and can't even do that right.

    Crap, crap, crap. Oh, did I mention how crap Flash on Linux is?

  5. #5
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default

    Quote Originally Posted by agd5f View Post
    Adobe's flash does not use hw acceleration on the open source drivers.
    still the facts are that with stock jaunty drivers it consumed lots of cpu time but at least worked, now it's unusable, too much slow and choppy..

    i did include a lot of random informations because i don't develop and i don't know how and if this could be useful..

  6. #6
    Join Date
    Dec 2007
    Posts
    2,277

    Default

    did you also change the version of flash you are using?

  7. #7
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default

    i'd say, no..

    i have 10.0.32.18

  8. #8

    Default

    Can you post the output of:
    Code:
    $ dmesg | grep drm
    I suspect you have a KMS kernel without KMS support on mesa/ati.

  9. #9
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,567

    Default

    Wait a minute.... Jaunty? 8.10? You didn't happen to be running the proprietary driver at that time? Since open drivers don't support GLSL (yet) which Adobe Flash uses for acceleration whereas proprietary drivers do.

  10. #10
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default

    ofcourse:
    Code:
    [   19.382778] [drm] Initialized drm 1.1.0 20060810
    [   19.691260] [drm] radeon default to kernel modesetting DISABLED.
    [   19.692972] [drm] Initialized radeon 1.31.0 20080528 for 0000:01:00.0 on minor 0
    [   29.620282] [drm] Setting GART location based on new memory map
    [   29.620294] [drm] Loading R500 Microcode
    [   29.620346] [drm] Num pipes: 1
    [   29.620358] [drm] writeback test succeeded in 1 usecs
    [   31.426081] Modules linked in: binfmt_misc bridge stp bnep vboxnetadp vboxnetflt vboxdrv video output w83627hf hwmon_vid p4_clockmod lp snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm tuner_simple tuner_types tea5767 snd_seq_dummy snd_seq_oss tuner tvaudio snd_seq_midi tda7432 msp3400 snd_rawmidi snd_seq_midi_event bttv radeon snd_seq ir_common ttm snd_timer snd_seq_device v4l2_common videobuf_dma_sg iTCO_wdt iTCO_vendor_support drm videobuf_core btcx_risc snd tveeprom i2c_algo_bit soundcore gspca_pac207 gspca_main psmouse intel_agp agpgart snd_page_alloc shpchp videodev serio_raw ppdev v4l1_compat pcspkr parport_pc parport usbhid 8139too 8139cp mii fbcon tileblit font bitblit softcursor

    edit: i'd add that in my lappy i have an intel 1.6ghz and intel gma(something), and flash (yes, adobe) works smoothly..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •