Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: fglrx 9.8 - Guildwar corruption

  1. #1
    Join Date
    Jan 2009
    Posts
    515

    Default fglrx 9.8 - Guildwar corruption

    Hello folks

    I have some problems running Guildwar with fglrx 9.8 under Arch 64.
    Actually the game installs/startup perfectly. But when I enter the char selection screen, I get the chessboard of doom. At least something, which is similar to that old bugger.

    That I have fixed, by starting the game in window mode. When I'm within the game, there is no problem going fullscreen. BUT...

    I get some odd texture corruptions. The corruption is noticable if you stand in a long distance from the texture.

    I took a screenshots of the corruption;
    http://img195.imageshack.us/img195/9...ildwardist.png

    You see the distortion within the red markings, and the same kind of texture (closer), without distortion in the green marking.

    Actually the first time i load the game, there aren't any distortion. But when I jump to another place within the game, the distortion starts to appear. It seems like memory problems?

    And here is a pastebin of the err and warnings my console get spammed with:
    http://pastebin.com/m26c96442

    I got these setting in my user.reg file:
    [Software\\Wine\\Direct3D]
    "DirectDrawRenderer"="opengl"
    "MaxFragmentUniforms"="1024"
    "MaxVaryings"="52"
    "MaxVertexUniforms"="1024"
    "OffscreenRenderingMode"="fbo"
    "PixelShaderMode"="enabled"
    "UseGLSL"="disabled"
    "VertexShaderMode"="hardware"
    "VideoMemorySize"="1024"

    I have tried with/without UseGLSL enabled, and backbuffer instead of fbo. pbuffer crash the game. Every settings gave the same corruptions.

    I am willing to patch wine for getting this to work proberly.
    Thx for your help.

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by tball View Post
    Hello folks

    I have some problems running Guildwar with fglrx 9.8 under Arch 64.
    Actually the game installs/startup perfectly. But when I enter the char selection screen, I get the chessboard of doom. At least something, which is similar to that old bugger.

    That I have fixed, by starting the game in window mode. When I'm within the game, there is no problem going fullscreen. BUT...

    I get some odd texture corruptions. The corruption is noticable if you stand in a long distance from the texture.

    I took a screenshots of the corruption;
    http://img195.imageshack.us/img195/9...ildwardist.png

    You see the distortion within the red markings, and the same kind of texture (closer), without distortion in the green marking.

    Actually the first time i load the game, there aren't any distortion. But when I jump to another place within the game, the distortion starts to appear. It seems like memory problems?

    And here is a pastebin of the err and warnings my console get spammed with:
    http://pastebin.com/m26c96442

    I got these setting in my user.reg file:
    [Software\\Wine\\Direct3D]
    "DirectDrawRenderer"="opengl"
    "MaxFragmentUniforms"="1024"
    "MaxVaryings"="52"
    "MaxVertexUniforms"="1024"
    "OffscreenRenderingMode"="fbo"
    "PixelShaderMode"="enabled"
    "UseGLSL"="disabled"
    "VertexShaderMode"="hardware"
    "VideoMemorySize"="1024"

    I have tried with/without UseGLSL enabled, and backbuffer instead of fbo. pbuffer crash the game. Every settings gave the same corruptions.

    I am willing to patch wine for getting this to work proberly.
    Thx for your help.
    realy wait for the 9-9 catalyst 9.8 has broken openGL extansions used by wine.

  3. #3
    Join Date
    Jan 2009
    Posts
    515

    Default

    You think that is what causing the distortion?

    Its just I have read about one, which got it to work with a memory patch for wine? But I don't know which patch he is talking about,

  4. #4
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by tball View Post
    You think that is what causing the distortion?

    Its just I have read about one, which got it to work with a memory patch for wine? But I don't know which patch he is talking about,
    i can reproduse a bug in wine/oblivion on 9-7/9-8 shader flickering in rooms and strips on the water in the outside.

    on 9.9 beta the shader flickering is patched.

    the openGL part in 9.9 has a full rework and more openGL3.2 features used by wine.

  5. #5
    Join Date
    Jan 2009
    Posts
    515

    Default

    @Qaridarium

    Think you got a private message. ;-)

  6. #6
    Join Date
    Jan 2009
    Posts
    515

    Default

    Any other with suggestions?

  7. #7
    Join Date
    Jan 2009
    Posts
    515

    Default

    This is what it looks like, after playing1 hour.

    http://img197.imageshack.us/img197/3...ldwardist1.png

    Any ideas?

  8. #8
    Join Date
    Mar 2009
    Posts
    203

    Default

    There's a similar bug in NWN2, but I figured that i was related to shadows(which many version ago already had a general problem even under windows + nVidia card--thought that it may have re-appeared), and the fade in/out of objects..

    (This was under 9.7 + Ubuntu 9.04 x86-64, haven't played it since installing 9.8, but AMD also forgot to include part of the package, a prog/script to escalate CCC privileges in Ubuntu, solvable by pre-pending gksu to start up in menu item. Needed this right away since catalyst has memory problems wrt Desktop Resolution...)
    MSI GT725-074US:
    Intel Core 2 Duo P8600, 4GB DDR2-800, 320GB 7200RPM WDC WD3200BEKT-22F3T0, ATI Mobility Radeon HD 4850 512MB GDDR3, 8x Super multi DVD+/-RW, 1680x1050 (17"), 9 cell battery

    Ubuntu 8.10 x86-64 (current updates) catalyst 9.3
    Windows Vista Home Premium 32b SP1 (current update) still on shipped catalyst(8.12 I think, MSI packed -- lazy)

  9. #9
    Join Date
    Jan 2009
    Posts
    515

    Default

    @cutterjohn

    Do you have any solutions to the corruption?
    It didn't help turning of shadow ingame.

  10. #10
    Join Date
    Jan 2009
    Posts
    515

    Default

    BTW, have tried fglrx 9.9 ~ alpha.
    I hope it is fixed within final 9.9

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •