Results 1 to 9 of 9

Thread: [Radeon + KMS + Karmic + X1400] Screen blanks out once in a while

  1. #1
    Join Date
    Sep 2009
    Posts
    16

    Default [Radeon + KMS + Karmic + X1400] Screen blanks out once in a while

    Hi

    I'm using latest Karmic Build with the Xorg-Edgers PPA
    everything's working fine, compiz, 3D games... but
    my screen gets black for 1 sec sometimes, mostly while watching videos
    oder playing 3D games, on normal Desktop usage, even with compiz enabled,
    everything's ok. when it goes black, it looks a bit like shutting off an old crt monitor. Im using a Dell G2410 Monitor via DVI with the Dockingstation of my Thinkpad.
    Does anybody know why this is happening, or better how to resolve it?

    greetings from germany

    killigrew

  2. #2
    Join Date
    Dec 2007
    Posts
    2,327

    Default

    Sounds like a display underflow issue. The DisplayPriority option needs to be ported to kms. To test it you can disable kms and add:
    Option "DisplayPriority" "HIGH"
    to the device section of your config.

  3. #3
    Join Date
    Sep 2009
    Posts
    16

    Default

    Hi

    didn't help, with kms, without kms and with DisplayPriority High, alway the same Problems.

  4. #4
    Join Date
    Apr 2008
    Posts
    101

    Default

    are you using Ubuntu Karmic? Check System->Einstellungen->Energieverwaltung.

  5. #5
    Join Date
    Sep 2009
    Posts
    16

    Default

    Hi, no, that was not the solution.
    When I start crrcsim (an RC Plane Simulator) the screen goes black completely and comes back on only after shutting down the game via alt+F4.

  6. #6
    Join Date
    Jan 2009
    Posts
    117

    Default

    Quote Originally Posted by Killigrew View Post
    Hi, no, that was not the solution.
    When I start crrcsim (an RC Plane Simulator) the screen goes black completely and comes back on only after shutting down the game via alt+F4.
    Sounds like program could be using Direct color visual which is known to be buggy. Can you change it to use double buffering from config?

  7. #7
    Join Date
    Sep 2009
    Posts
    16

    Default

    The problem occures only if the monitor is connected via dvi.
    Via vga there is no flickering or anything at all.

  8. #8
    Join Date
    Sep 2009
    Posts
    28

    Default

    Sounds familiar...

    https://bugzilla.redhat.com/show_bug.cgi?id=501601

    Even clean fedora 11 without fancy KMS stuff suffers this.


    Quote Originally Posted by Killigrew View Post
    Hi

    I'm using latest Karmic Build with the Xorg-Edgers PPA
    everything's working fine, compiz, 3D games... but
    my screen gets black for 1 sec sometimes, mostly while watching videos
    oder playing 3D games, on normal Desktop usage, even with compiz enabled,
    everything's ok. when it goes black, it looks a bit like shutting off an old crt monitor. Im using a Dell G2410 Monitor via DVI with the Dockingstation of my Thinkpad.
    Does anybody know why this is happening, or better how to resolve it?

    greetings from germany

    killigrew

  9. #9
    Join Date
    Sep 2009
    Posts
    16

    Default

    Hi

    yes, some of the description are looking familiar indeed

    greetings, and thanks for your afford
    Last edited by Killigrew; 09-22-2009 at 05:49 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •