Results 1 to 8 of 8

Thread: problems with Catalyst 9.9

  1. #1
    Join Date
    Sep 2009
    Posts
    3

    Default problems with Catalyst 9.9

    Hello,

    I recently bought a Lenovo Thinkpad T500 laptop with an ATI Mobility Radeon HD3650 graphics card and i'm trying to install the Catalyst 9.9 (fglrx) driver on a fresh install of Ubuntu Studio 9.04.

    I've read several topics on how to do it on this and other forums but have run into an error i'm not able to resolve. After installing the Catalyst driver, configuring xorg.conf with "aticonfig --initial" and rebooting, i can log in to X, open the Catalyst manager and the system seems to be working, although there's an awful lot of frame skipping when moving windows. However, when i try to launch a 3d application (ie. nexuiz) i get errors. I tried running glxinfo and glxgears but this is what i get:

    Code:
    stefanos@lap:~$ glxgears
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  135 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  14
      Current serial number in output stream:  14
    While trying to find a solution, i've completely uninstalled the driver, i've checked that there's no other ati driver on my system and also i located and deleted any file that had fglrx in it, then reinstalled. Same thing happens. In my Xorg.0.log i found these lines, that seem to point to the source of the problem:

    Code:
    (II) fglrx(0): driver needs X.org 1.4.x.y with x.y >= 99.906
    (WW) fglrx(0): could not detect X server version (query_status=-1)
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. 
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    in dmesg i found these 2 lines that seem relevant with the issue:

    Code:
    [   25.316824] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [   25.318311] fglrx: Unknown symbol __call_bad_lock_func
    So, now i have lots of frame skipping and no 3d acceleration. Any help to resolve any of these 2 issues will be greatly appreciated.

    thanks in advance,
    stefanos
    Last edited by delete; 09-18-2009 at 05:38 AM. Reason: added dmesg info

  2. #2
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Your kernel is lacking a required symbol. Could try an Ubuntu 9.10 kernel.

  3. #3
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    The first error is from a too new libdrm2, so you basically can forget the system without libdrm2 downgrade. The 2nd seems to be specific to the used kernel. I would get rid of that system if you want to use fglrx. You definitely can NOT use an unpatched U 9.10 kernel, because of 2 things:

    a) would require 9-10 driver
    b) libc6 is too old in your system
    Last edited by Kano; 09-18-2009 at 05:49 AM.

  4. #4
    Join Date
    Sep 2009
    Posts
    3

    Default

    thanks for the replies. do you reckon these issues will be resolved if i try a fresh install of Ubuntu 9.10 alpha 1, which has the 9.10 driver and newest libc6?

  5. #5
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    You can do this or you could get a new Kanotix snapshot is you like KDE 3.5 or 4.2.4 *g*

  6. #6
    Join Date
    Sep 2009
    Posts
    3

    Default

    Kano: thanks for the help. Unfortunately, i need a tested, sturdy and optimized system with realtime preemption without going into the process of compiling the kernel myself, so Kanotix is not an option for me.

    While googling around i found out that the 3d issue is probably a bug in the rt kernel. I'm downloading Ubuntu Studio Alpha 6 now, will give it a shot and report back.

  7. #7
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    The 2nd part is the kernel, the first is libdrm2 too new.

  8. #8
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Kano: Thanks for correction.
    delete: I'd assume rather a feature than a bug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •