Results 1 to 3 of 3

Thread: Any success stories with fedora 7 test3?

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Posts
    2

    Default Any success stories with fedora 7 test3?

    My rebuild: rpmbuild -ba nvidia-kmod.spec --target=i686 --define "kvariants ''"
    from http://rpm.livna.org/fedora/development/SRPMS/nvidia-kmod-1.0.9755-1.2.6.20_[/url][B]1.2967.fc7.src.rpm
    for kernel 2.6.20-1.3054.fc7
    fails with:

    <snip>
    NVIDIA: left KBUILD.
    + popd
    ~/rpmbuild/BUILD/nvidia-kmod-1.0.9755
    + exit 0
    Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.36737
    + umask 022
    + cd /home/alphonse/rpmbuild/BUILD
    + cd nvidia-kmod-1.0.9755
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /var/tmp/nvidia-kmod-1.0.9755-1.2.6.20_1.3054.fc7-root-alphonse
    + for kvariant in ''\'''\'''
    + install -D -m 0644 _kmod_build_/usr/src/nv/nvidia.ko /var/tmp/nvidia-kmod-1.0.9755-1.2.6.20_1.3054.fc7-root-alphonse/lib/modules/2.6.20-1.3054.fc7/extra/nvidia/nvidia.ko
    + chmod u+x /var/tmp/nvidia-kmod-1.0.9755-1.2.6.20_1.3054.fc7-root-alphonse/lib/modules/2.6.20-1.3054.fc7/extra/nvidia/nvidia.ko
    + /usr/lib/rpm/find-debuginfo.sh /home/alphonse/rpmbuild/BUILD/nvidia-kmod-1.0.9755
    extracting debug info from /var/tmp/nvidia-kmod-1.0.9755-1.2.6.20_1.3054.fc7-root-alphonse/lib/modules/2.6.20-1.3054.fc7/extra/nvidia/nvidia.ko
    581 blocks
    + /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
    /var/tmp/rpm-tmp.36737: line 39: /usr/lib/rpm/check-rpaths: No such file or directory
    error: Bad exit status from /var/tmp/rpm-tmp.36737 (%install)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.36737 (%install)
    Last edited by alphonse; 04-11-2007 at 08:48 AM.

  2. #2

    Default

    Did you try installing the NVIDIA binary instead of building it as an RPM?

  3. #3
    Join Date
    Apr 2007
    Posts
    2

    Default

    Actually at the moment I installed something else:

    Installed: nvidia-graphics9755.i386 1:1.0_9755-86.fc6.91.at
    Dependency Installed: nvidia-graphics-helpers.i386 0:0.0.18-19.fc6.91.at nvidia-graphics9755-libs.i386 1:1.0_9755-86.fc6.91.at

    Rebooting now & fingers crossed. Will edit this after I try the binary thingy.

    If anyone else has fedora rawhide & nvidia please post here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •