Results 1 to 2 of 2

Thread: Help needed with ThinkPad T60 dock/DVI

  1. #1
    Join Date
    Sep 2009
    Location
    Tampere, Finland
    Posts
    12

    Default Help needed with ThinkPad T60 dock/DVI

    Hi,

    I've tried with Ubuntu Jaunty stock radeonhd, ati (radeon) and fglrx drivers. All of them have various problems while open source radeonhd seemed to be the best compromize. I'm my using ThinkPad T60 at work so realiable switching between laptop panel, VGA projector presentations and DVI as docked with Dell monitor is required. I'm using xrandr to switch modes.

    Some improvement to stability is achieved with GIT version of radeonhd (as instructed in https://help.ubuntu.com/community/RadeonHD). 3D graphics via DRI and EXA cannot be enabled without stability problems.

    My colleagues more familiar with AMD/ATI world recommend to use the ati radeon driver (http://cgit.freedesktop.org/xorg/driver/xf86-video-ati) instead.

    The first problem I noticed is that DVI is not recognized with xf86-video-ati-6.12.4.tar.bz2.

    My /etc/X11/xorg.conf looks like
    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver "radeon"
    	#Driver "radeonhd"
    	#Option "DRI"
    	#Option "AccelMethod"  "EXA"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	SubSection "Display"
              Depth 24
              Virtual 1980 1080
           EndSubSection
    EndSection
    
    Section "DRI"
            Mode         0666
    EndSection
    I couldn't find a way to attach text files so here are hopefully essential parts of /var/log/Xorg.0.log

    Code:
    ...
    
    (--) PCI:*(0@1:0:0) ATI Technologies Inc M52 [Mobility Radeon X1300] rev 0, Mem @ 0xd8000000/134217728, 0xee100000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
    
    ...
    
    (--) RADEON(0): Chipset: "ATI Mobility Radeon X1300" (ChipID = 0x7149)
    
    ...
    
    (II) RADEON(0): ATOM BIOS detected
    (II) RADEON(0): ATOM BIOS Rom: 
            SubsystemVendorID: 0x17aa SubsystemID: 0x2006
            IOBaseAddress: 0x2000
            Filename: BR25482.bin 
            BIOS Bootup Message: 
    M64CSP/M62CSP/M54CSP/M52CSP BIOS                             #              
    
    ...
    
    (WW) RADEON(0): LVDS Info:
    XRes: 1400, YRes: 1050, DotClock: 108000
    HBlank: 288, HOverPlus: 48, HSyncWidth: 112
    VBlank: 16, VOverPlus: 1, VSyncWidth: 3
    encoder: 0x15
    encoder: 0xf
    encoder: 0x13
    (II) RADEON(0): Output VGA-0 using monitor section Configured Monitor
    (II) RADEON(0): I2C bus "VGA-0" initialized.
    (II) RADEON(0): Output LVDS has no monitor section
    (II) RADEON(0): I2C bus "LVDS" initialized.
    (II) RADEON(0): Output DVI-0 has no monitor section
    (II) RADEON(0): I2C bus "DVI-0" initialized.
    (II) RADEON(0): Port0:
      XRANDR name: VGA-0
      Connector: VGA
      CRT1: INTERNAL_KLDSCP_DAC1
      DDC reg: 0x7e40
    (II) RADEON(0): Port1:
      XRANDR name: LVDS
      Connector: LVDS
      LCD1: INTERNAL_LVTM1
      DDC reg: 0x7e60
    (II) RADEON(0): Port2:
      XRANDR name: DVI-0
      Connector: DVI-I
      DFP1: INTERNAL_KLDSCP_TMDS1
      DDC reg: 0x7e50
    (II) RADEON(0): I2C device "VGA-0:E-EDID segment register" registered at address 0x60.
    (II) RADEON(0): I2C device "VGA-0:ddc2" registered at address 0xA0.
    Dac detection success
    (II) RADEON(0): Output: VGA-0, Detected Monitor Type: 0
    finished output detect: 0
    (II) RADEON(0): I2C device "LVDS:E-EDID segment register" registered at address 0x60.
    (II) RADEON(0): I2C device "LVDS:ddc2" registered at address 0xA0.
    (II) RADEON(0): Output: LVDS, Detected Monitor Type: 2
    (II) RADEON(0): EDID data from the display on output: LVDS ----------------------
    (II) RADEON(0): Manufacturer: LEN  Model: 4022  Serial#: 0
    (II) RADEON(0): Year: 2006  Week: 37
    (II) RADEON(0): EDID Version: 1.3
    (II) RADEON(0): Digital Display Input
    (II) RADEON(0): Max Image Size [cm]: horiz.: 29  vert.: 21
    (II) RADEON(0): Gamma: 2.20
    (II) RADEON(0): DPMS capabilities: StandBy Suspend Off
    (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
    (II) RADEON(0): First detailed timing is preferred mode
    (II) RADEON(0): redX: 0.610 redY: 0.330   greenX: 0.300 greenY: 0.530
    (II) RADEON(0): blueX: 0.150 blueY: 0.130   whiteX: 0.313 whiteY: 0.329
    (II) RADEON(0): Supported VESA Video Modes:
    (II) RADEON(0): 640x480@60Hz
    (II) RADEON(0): 800x600@60Hz
    (II) RADEON(0): 1024x768@60Hz
    (II) RADEON(0): Manufacturer's mask: 0
    (II) RADEON(0): Supported Future Video Modes:
    (II) RADEON(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    (II) RADEON(0): Supported additional Video Mode:
    (II) RADEON(0): clock: 108.0 MHz   Image Size:  287 x 215 mm
    (II) RADEON(0): h_active: 1400  h_sync: 1448  h_sync_end 1560 h_blank_end 1688 h_border: 0
    (II) RADEON(0): v_active: 1050  v_sync: 1051  v_sync_end 1054 v_blanking: 1066 v_border: 0
    (II) RADEON(0): Supported additional Video Mode:
    (II) RADEON(0): clock: 90.0 MHz   Image Size:  287 x 215 mm
    (II) RADEON(0): h_active: 1400  h_sync: 1448  h_sync_end 1560 h_blank_end 1688 h_border: 0
    (II) RADEON(0): v_active: 1050  v_sync: 1051  v_sync_end 1054 v_blanking: 1066 v_border: 0
    (WW) RADEON(0): Unknown vendor-specific block f
    (II) RADEON(0):  LTD141EN9B
    (II) RADEON(0): EDID (in hex):
    (II) RADEON(0):         00ffffffffffff0030ae224000000000
    (II) RADEON(0):         25100103801d1578ea6f959c544c8726
    (II) RADEON(0):         21505421080081800101010101010101
    (II) RADEON(0):         010101010101302a7820511a10403070
    (II) RADEON(0):         13001fd71000001825237820511a1040
    (II) RADEON(0):         307013001fd7100000180000000f0090
    (II) RADEON(0):         43329043280f010030649055000000fe
    (II) RADEON(0):         004c5444313431454e39420a2020003d
    finished output detect: 1
    (II) RADEON(0): I2C device "DVI-0:E-EDID segment register" registered at address 0x60.
    (II) RADEON(0): I2C device "DVI-0:ddc2" registered at address 0xA0.
    (II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
    Unhandled monitor type 0
    finished output detect: 2
    finished all detect
    
    ...
    In the log X claims that DVI is disconnected

    Code:
    ingalsuo@4FIL31884:~$ grep -i DVI Xorg.0.log-radeon-20090916
    (II) RADEON(0): Output DVI-0 has no monitor section
    (II) RADEON(0): I2C bus "DVI-0" initialized.
      XRANDR name: DVI-0
      Connector: DVI-I
    (II) RADEON(0): I2C device "DVI-0:E-EDID segment register" registered at address 0x60.
    (II) RADEON(0): I2C device "DVI-0:ddc2" registered at address 0xA0.
    (II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
    (II) RADEON(0): Output: DVI-0, Detected Monitor Type: 0
    (II) RADEON(0): Output DVI-0 disconnected
    Is there any way to tell radeon driver to try harder to explore DVI via xorg.conf?

  2. #2
    Join Date
    Sep 2009
    Location
    Tampere, Finland
    Posts
    12

    Default

    Sorry for duplicate posting, please ignore this thread. As excuse I'm a newbie here and thought this one didn't make it. See http://phoronix.com/forums/showthread.php?t=19290 instead.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •