Results 1 to 10 of 16

Thread: Radeon driver fails with ThinkPad T60 dock/DVI

Threaded View

  1. #11
    Join Date
    Sep 2009
    Location
    Tampere, Finland
    Posts
    12

    Default

    Hi again. I'm now running Karmic on the same T60 and have kind of similar problems as in Jaunty:

    • Radeon cannot activate DVI-0
    • Radeonhd works better compared to radeonhd in Jaunty but is still sometimes (once/twice in a day) freezing the PC with Compiz desktop effects.


    Here are links to my Xorg.0.log files from boot to effort to activate DVI with xrandr

    Radeonhd http://pastebin.com/m77ec206a

    Radeon http://pastebin.com/m6f39d21

    I tried to activate DVI with radeon with these commands.

    Code:
    xrandr --newmode 1680x1050 146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    xrandr --addmode DVI-0 1680x1050
    xrandr --output DVI-0 --mode 1680x1050
    With the first attempt the T60 panel goes off and on like it would try to do something on DVI but nothing happens in the Dell LCD side. With second and later retries there is no flash in the local panel.

    I have also problem with radeonhd with corrupted display after opening T60 panel lid or in resume after suspend (didn't try with radeon). That used to work in Jaunty.

    BR,
    Seppo
    Last edited by seppoi; 10-23-2009 at 07:05 AM. Reason: typo

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •