Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Mesa 7.6 Gets Pulled Into Ubuntu 9.10

  1. #1
    Join Date
    Jan 2007
    Posts
    15,423

    Default Mesa 7.6 Gets Pulled Into Ubuntu 9.10

    Phoronix: Mesa 7.6 Gets Pulled Into Ubuntu 9.10

    Ubuntu 9.10 had its beta release last week and the final release is coming in just three weeks, but this late in the release cycle, it has been decided to pull in the final Mesa 7.6 version. Pulling in this newer code that provides OpenGL acceleration on Linux provides numerous bug-fixes along with support for a greater number of OpenGL extensions on different hardware and other improvements.

    http://www.phoronix.com/vr.php?view=14241

  2. #2
    Join Date
    Aug 2007
    Posts
    437

    Default

    ZOMG My 2900XT has been sitting in the closet gathering rust and dust for almost 2 years! Meanwhile I have been living on the nVidia blob and a 8800Ultra happily ever after. Everyday I read the news that R600/R700 3D is not coming up makes me feel happier because I did the right thing and tossed it not too late.

    Guess what, I'm actually thinking about donating my 2900XT to some X.Org developer. Who wants one?! Buy the way you need at least a 550W PSU, tons of 12V Amps to power it up.

  3. #3

    Default

    this latest Mesa code in Ubuntu does not provide ATI R600/700 3D acceleration support by default
    So uh, anyone know if there's an easy way to get this? PPA etc...

  4. #4
    Join Date
    Aug 2007
    Location
    Poland
    Posts
    215

    Default

    Is there any benchmark how does it work with ATI R300 series?
    Is it worth upgrading Kubuntu from 9.04 + KDE 4.3.2 to 9.10 with ATI card?

  5. #5
    Join Date
    Oct 2008
    Posts
    3,219

    Default

    I'm also wondering about the radeon performance. I don't think I've seen any benchmarks of the new rewritten codebase except for a couple when it first came out and wasn't optimized very well.

  6. #6
    Join Date
    May 2008
    Posts
    343

    Default

    Quote Originally Posted by Mr_Alien_Overlord View Post
    So uh, anyone know if there's an easy way to get this? PPA etc...
    Yes, the mesa packages in the xorg-edgers PPA have the r600 support enabled. You will also need a newer kernel than the one in Karmic, and this you can find in the Mainline Kernel PPA.

  7. #7
    Join Date
    May 2008
    Posts
    343

    Default

    nor is ATI kernel mode-setting enabled for Ubuntu 9.10
    It is enabled in the build, but not enabled by default run-time. So you just have to add "radeon.modeset=1" to the boot options.

  8. #8
    Join Date
    Dec 2007
    Posts
    248

    Default

    ... and kwin compositioning is broken after the upgrade (on radeon)...

  9. #9
    Join Date
    May 2008
    Posts
    343

    Default

    Quote Originally Posted by val-gaav View Post
    ... and kwin compositioning is broken after the upgrade (on radeon)...
    Bug link, please?

  10. #10
    Join Date
    Sep 2008
    Posts
    201

    Default

    Quote Originally Posted by val-gaav View Post
    ... and kwin compositioning is broken after the upgrade (on radeon)...
    Working fine here on my X1600 mobility.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •