hi everybody,
This is the first time that i use linux, and I have encounter some problem when i tried to install my fglrx driver for my radeon 9800 xt on fedora core 6.

I am using the driver from the livna.org

First i install the livna packet in console (without starting X)
rpm -ivh livna-release-6.rpm

then i install the fglrx driver
yum install glx-utils
yum install kmod-fglrx

and it installs some dependencies with the driver

since i have 2 monitors, i use aticonfig --initial=dual-head

Then i startx.

I turns out that driver does not work properly.
this is my fglrxinfo

libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)



display: :0.0 screen: 1
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)



the following is my xorg.conf

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
Screen "aticonfig-Screen[1]" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "NEC MultiSync LCD1712"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 76.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "VideoOverlay" "on"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection


I have been googling for a week, but i still can't fix it.
Thanks for everyone's help