Results 1 to 2 of 2

Thread: Radeon driver and RV250 (Radeon 9000)

  1. #1
    Join Date
    Sep 2007

    Default Radeon driver and RV250 (Radeon 9000)

    Since many people are posting issues they've come across, I was wondering about the current situation with ATI Radeon drivers and ATI R200-based cards, particularly mobile RV250 ATI 9000 cards.

    I've tested several distros, mostly developmental versions but there has been a pattern of buggy configurations. On all the Live CDs or DVDs, there has been some sort of crash or failure when trying to enable desktop effects.

    Here is the rundown of results and the distro experimented with:

    Ubuntu - about a few seconds afterwards, the screen freezes. The mouse cursor is 'stuck' and there is an entire system lockup. Keys don't work. A complete restart of the laptop is requird
    Kubuntu - practically the same outcome
    OpenSUSE - A message showing 'it can't enable effects' or something to that effect... I don't recall exactly the response but desktop effects doesn't work properly or enable fully. However, one type of effects works - XRendering.... OpenGL setting of effects DOESN'T WORK and the message just expressed occurs
    Fedora Alpha 12 - the desktop turns black after enabling 'Desktop Effects' (this is the Gnome desktop) and then the login screen displays. After checking the settings, desktop effects is not changed and displays that it's not enabled.

    I'm wondering if the problem is multi or a combination of compiz/desktop effects bugs, ATI bugs and X (xorg)? But, I am convinced that the ATI radeon drivers are definitely a major factor.

    What are the chances of the bugs being fixed soon is what I'd like to know if possible. Anyway, just thought I'd post for those who have similar, yet older ATI cards, both desktop and mobile. I assume the same results occur for both as whatever is in the same series and generation of cards probably is effected.

  2. #2
    Join Date
    Dec 2007


    I suspect AGP issues, assuming your card is AGP. You might try changing the AGP mode:
    Option "AGPMode" "X"
    where X = 1 or 2 or 4
    or forcing the chip to use the on board gart block:
    Option "BusType" "PCI"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts