Results 1 to 6 of 6

Thread: Mobility X1600 + kernel .31

  1. #1
    Join Date
    Jul 2008
    Posts
    39

    Default Mobility X1600 + kernel .31

    I have ATI Mobility Radeon X1600, perhaps I got some older package, but according to all info I read KMS and 3D should work, yet I get this error:

    "(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
    [dri] radeon kernel module version is 2.0.0 but version 1.17.0 or newer is needed."

    My package versions (on arch linux x86_64) are:

    kernel26 2.6.31.3-1
    mesa 7.5.1-2
    libgl 7.5.1-2
    libdrm 2.4.13-1
    xf86-video-ati 6.12.4-1

    Is mesa 7.5.1 too old for KMS with radeon? Am I missing something? I found a bugrep with this exact error specific for X1600 cards on Ubuntu as well so I'm wondering.

    Btw. isn't 2.0.0 > 1.17.0 ?

  2. #2
    Join Date
    Dec 2007
    Posts
    2,337

    Default

    Your xf86-video-ati and mesa must be built with kms support; they must be built against libdrm_radeon. For mesa you need 7.6 or newer.

  3. #3
    Join Date
    Jul 2008
    Posts
    39

    Default

    Then their (Arch) wiki page about KMS support for R500s is wrong. Ok, thanks, I'll update from aur.

  4. #4
    Join Date
    Sep 2008
    Posts
    201

    Default

    Quote Originally Posted by Almindor View Post
    Is mesa 7.5.1 too old for KMS with radeon? Am I missing something? I found a bugrep with this exact error specific for X1600 cards on Ubuntu as well so I'm wondering.
    I have that card, KMS & DRI2 are working on it with the standard ubuntu 9.10 packages.

  5. #5
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,788

    Default

    Quote Originally Posted by agd5f View Post
    Your xf86-video-ati and mesa must be built with kms support; they must be built against libdrm_radeon.
    Aren't we supposed to use libdrm with the "--enable-radeon-experimental-api" configure option?

    http://www.x.org/wiki/radeonBuildHow...3af1bbd64ca35e

    I did that with my HD4870 and still get the version mismatch error. Firmware is loaded. Kernel is 2.6.33 rc4, xf86-video-ati 6.12.4, Mesa 7.7, X.Org 7.5 (server 1.7.4), libdrm 2.4.17. Basically all requirements stated in the above wiki are matched or exceeded. KMS works during booting, but all breaks as soon as X starts.
    Last edited by RealNC; 01-17-2010 at 08:00 AM.

  6. #6
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,033

    Default

    Not exactly; "latest ddx from master branch (6.12.99)" is still missing, you're using 6.12.4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •