Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Crazy ATI!!

  1. #1
    Join Date
    Nov 2009
    Posts
    7

    Default Crazy ATI!!

    Hi everybody,
    i'm came here for some help.. i hope to find some one!!
    sorry for my english but i'm from italy!!!

    well the PROBLEM is the following:

    i have tried to install the ATI driver 9.10 (mobility radeon hd 3650) on Kubuntu 9.10 at the first time it boot then all comes all black doesn't boot anymore.
    I did the install by terminal and also by hardware.
    i have tried also with envyng.

    and the black screen happen after the second reboot:

    i install the drivers,
    i reboot and all works (even the effects),
    i reboot for the second time and nothing works: kubuntu logo with the loading bar starts and then all become black with the CAPS LOCK that is intemitted on/off.

  2. #2
    Join Date
    Nov 2009
    Posts
    7

    Default

    can some one help me??
    like give me some link how to install it or something...
    PLEASE!

  3. #3
    Join Date
    Jul 2007
    Posts
    50

    Default

    Quote Originally Posted by Noga View Post
    can some one help me??
    like give me some link how to install it or something...
    PLEASE!
    Sounds like a kernel panic.

    You should try and boot into "single user mode".

    To do this, at Grub, edit the kernel line and put the word "single" at the end of it.

    Hopefully then you can drop to a shell and remove the driver.

  4. #4
    Join Date
    Nov 2009
    Posts
    7

    Default

    ok but i tried to do it in the recovery mod. i got into the terminal without the graphic view and then i followed some guide to uninstall the driver and at the end i uninstall even the KDE.

    I just wanted to know then if there is some "good" way to install the drivers or something?? what do you think?

  5. #5
    Join Date
    Jul 2007
    Posts
    50

    Default

    Quote Originally Posted by Noga View Post
    ok but i tried to do it in the recovery mod. i got into the terminal without the graphic view and then i followed some guide to uninstall the driver and at the end i uninstall even the KDE.

    I just wanted to know then if there is some "good" way to install the drivers or something?? what do you think?
    The only thing I've heard is that it's wise to delete the "/etc/ati" directory before installing new drivers. I'm new to ati cards though.

    If you could pastebin.org your xorg log and your messages log someone might be able to help you more.

    Bear in mind, that the Xorg.log file is refreshed each time that X starts.

    Evan.

  6. #6
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    Yeah, delete /etc/ati and then reinstall the drivers. Make sure you do "aticonfig -f --initial" after installation and before rebooting.

  7. #7
    Join Date
    Nov 2009
    Posts
    7

    Default

    do i have just to delete the folder before and type aticonfig -f --initial after and i suppose to be done??
    if does it work u are amazing!!!

  8. #8
    Join Date
    Jan 2009
    Posts
    515

    Default

    @Noga

    I think its because xorg someway defaults to 8 bit, which fglrx doesn't support.

    All you have to do, is to set it up to use DefaultDepth 24 bit in /etc/X11/xorg.conf. Like this:
    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	DefaultDepth	24
    EndSection
    I don't if thats your problem, but thats why I couldn't boot with my 3650. My computer would just be black too.

  9. #9
    Join Date
    Nov 2009
    Posts
    7

    Default

    @tball i cant find the xorg.conf in the kubuntu 9.10 ??

    @NeoBrain i cant find the ATI folder...??

  10. #10
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by Noga View Post
    @tball i cant find the xorg.conf in the kubuntu 9.10 ??

    @NeoBrain i cant find the ATI folder...??

    Well you should definitely have a xorg.conf file, if you want to use fglrx. Did you install the driver through the hardware drivers app within settings?

    If you don't have a xorg.conf file, it won't load fglrx. Instead it tries to load the oss radeon driver, and that won't work with fglrx installed :P So that might be our problem.

    Try run sudo aticonfig -f --initial, and see if you got a xorg.conf file within /etc/X11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •