Hi,

I have a laptop problem that is not really related to Linux (though I am a Linux user so I have full right to use this forum). I would appreciate if someone could help me.

I have a 3 year old Fujitsu-Siemiens laptop that stopped working yesterday. Basically, it's been switched off for around a day and after I started it up it worked for roughly 20mins. Then it just froze. After rebooting it would keep rebooting and shutting down itself every 3-4 seconds.
A few facts:
- it happens no matter if I am running on battery or ac
- the laptop doesn't reach booting stage (I tried inserting memtest cds) or even bios welcome screen
- I opened the laptop and removing RAM doesn't make any difference (the symptoms are the same)
- I had exactly the same problem 2 years ago when it was still on warranty and Fujitsu gave me a new motherboard.
- I continuously monitored the cpu and motherboard temperature and haven't had any warnings

I'd rather get myself a new laptop than pay for a new motherboard so I'd really like to make sure that there is no help for my motherboard (or any other component that could be broken). It seems to me that there could be something wrong with the power connector - unfortunately it is located in a really hard to reach place so I haven't looked at it yet. Looks like the current is too low or something like that. So far, looking at the motherboard, I see no signs of burns or exploding capacitors. The laptop's been lying on a table for the last few days so I'd definitely rule out any mechanical damage.

Feel free to ask any questions that might help.

Thanks in advance for all your help,

Wojtek