Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: My machine has suddenly become very noisy - what could the problem be?

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Posts
    446

    Default My machine has suddenly become very noisy - what could the problem be?

    Hi,

    My main desktop machine has suddenly become very noisy - any user activity is triggering a barrage of "pops" out of the speakers. The more intensive the use, the more pops I hear. Even scrolling the browser window with the mouse results in noise, so you can imagine how impractical playing DVDs has become. I know the speakers are OK because I get the same results with a pair of headphones plugged into the sound card's "Analog Out" jack socket instead.

    I've looked inside the PC's case and can't see any obvious problem. Can anyone suggest what might be going wrong, please? The sound card is an Audigy 2, and I am running a 2.6.31.5 kernel, just in case this might be a driver problem rather than a hardware problem.

    Thanks for any ideas,
    Chris

    Other points:
    - My sound card doesn't share an IRQ with anything else.
    - Audio-only applications don't seem to have a problem. (Not CPU-intensive enough? No video update?)
    - I am running Fedora 11, which puts PulseAudio between me and any audio.
    - Fedora 11 plays havok with my mixer settings. Could some combination of settings be creating interference on one of the output channels?
    Last edited by chrisr; 10-26-2009 at 05:02 PM.

  2. #2
    Join Date
    Sep 2009
    Location
    Detroit
    Posts
    8

    Default

    I would think it's a software issue or a loose audio jack on the soundcard.

  3. #3
    Join Date
    Jul 2007
    Posts
    446

    Default Loose S/PDIF cable?

    Quote Originally Posted by NullHead View Post
    I would think it's a software issue or a loose audio jack on the soundcard.
    I have currently resolved the problem by replacing the S/PDIF cable connecting my CD-RW drive to my Audigy2 card with an analogue one. So either the S/PDIF cable was inadequately shielded against electronic noise within the PC case, or the S/PDIF connector on my soundcard was dodgy. Fortunately, the Audigy2 has two analogue connectors.

    I'll try and find a better S/PDIF cable to settle the matter completely.

  4. #4
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,583

    Default

    Quote Originally Posted by chrisr View Post
    I have currently resolved the problem by replacing the S/PDIF cable connecting my CD-RW drive to my Audigy2 card with an analogue one. So either the S/PDIF cable was inadequately shielded against electronic noise within the PC case, or the S/PDIF connector on my soundcard was dodgy. Fortunately, the Audigy2 has two analogue connectors.

    I'll try and find a better S/PDIF cable to settle the matter completely.
    You really shouldn't have to use any spdif or analog cable from your cd-rw to your soundcard. digital audio should passthru crystal clear through the ide bus. If your using the analogue cable from your cd drive then you are letting it's DAC do all the work (and they are usually really piss poor dacs) and your sound card is really doing nothing but passing the audio signal along to it's outputs. Get rid of the cables and check your gains. Sounds like it's picking up interference through a analog in (mic/line in/cdrom) and see if muting those improve your situation.

  5. #5
    Join Date
    Jul 2007
    Posts
    446

    Default But if that's the case...

    Quote Originally Posted by deanjo View Post
    You really shouldn't have to use any spdif or analog cable from your cd-rw to your soundcard. digital audio should passthru crystal clear through the ide bus.
    Where does the digital audio "go", if it's coming off the IDE bus? How would I end up hearing it through the analogue speakers connected to my soundcard?

    There's a DVD-ROM drive connected to the IDE bus, as well as that CD-RW drive. Does the DVD drive need to be cabled to the soundcard so that I can watch DVDs too?

    I'm confused...

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    Digital data is read from the CD drive by the CPU, and sent to the D/A converters on your sound chip/card. The output of the D/A converters goes to the speakers.

    This used to be a massive task for the poor CPU but CPUs have become a lot faster since then and audio data rates haven't really gone up.

  7. #7
    Join Date
    Dec 2008
    Posts
    45

    Default

    I'm a little out of my depth here, but i think what your saying is
    you'll get less system noise if you remove the analog cable from CDrom
    to soundcard. Correct ?

    And what software do we use to play CD's ? Xmms, CDPlay and Grip (playback only)
    don't know about the presence/absence of this cable, and won't function properly.

  8. #8
    Join Date
    Nov 2009
    Posts
    3

    Default

    This sounds like a speaker shielding problem rather than a PC hardware problem. It's possible that some wires have gotten crossed that are producing the exact electronmagnetic frequency that is disturbing your speakers!

  9. #9
    Join Date
    Jul 2007
    Posts
    446

    Default I ruled out the speakers by plugging a pair of headphones in instead

    Quote Originally Posted by greentweak View Post
    This sounds like a speaker shielding problem rather than a PC hardware problem. It's possible that some wires have gotten crossed that are producing the exact electronmagnetic frequency that is disturbing your speakers!
    I heard the same noise through the headphones as I did through the speakers. Hence I knew the noise was from the soundcard itself.

    Removing the S/PDIF cable between the CD-RW drive and the soundcard has resolved the problem.

  10. #10
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,102

    Default

    At least in XMMS you need to go to the cd plugin options and tick the "digital" checkbox.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •