Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Unsupported Hardware watermark

  1. #1
    Join Date
    Mar 2008
    Location
    New Jersey
    Posts
    18

    Default Unsupported Hardware watermark

    Hello, I have an xfx Radeon HD 5770 card, and I know its not fully supported by the latest fglrx yet, but modesetting and 3d works to a degree. Is there a way to get rid of the AMD Unsupported Hardware watermark, as I know its not fully supported?

  2. #2
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    Code:
    #!/bin/sh
    DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
     sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    Have fun

  3. #3
    Join Date
    Dec 2008
    Posts
    13

    Default

    Quote Originally Posted by Kano View Post
    Code:
    #!/bin/sh
    DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
     sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done
    Have fun
    Wow, gross. I thought 9.10 was supposed to add 5750 and 5770 support. In any case many thanks. I have ubuntu 9.10 (catalyst and ubuntu) with a 5770 and that fixed the problem. The card seems okay so far. Seems kinda silly to have to binary hack the driver, but otherwise video playback, compiz, and related works. I'm having some cursor problems on my dual head when I get near certain areas of the screen the cursor disappears.

    Thanks again.

  4. #4
    Join Date
    Feb 2010
    Posts
    1

    Default watermark fix

    this fix works for Mandriva linux 2010.- as well. thanks!!

  5. #5
    Join Date
    May 2010
    Posts
    1

    Default

    This works on Linux Mint 8 64 bit too. Thanks!

  6. #6
    Join Date
    May 2010
    Posts
    11

    Question

    Hi, a month ago i had the same problem but with Kano's code it work, but now i update to ubuntu 10.4 and i can't turn on the "Meny->System->Preferences->"Appearence"" (portuguese ubuntu don't know the english word), so i wnet to hardware and drivers menu and it said to Activate the driver FGLRX ATI/AMD but i got this whindow:

    SystemError: installArchives() failed

    ALSO in update manager i have an update "fglrx(new instalation)" and when i try to install i got this error: (I will try to translate the best i can)
    first i got this window:
    "you have 1 broken package in your system ! use the filter "broken" to trace then."
    i close the window and then it star to install but pop other window:
    "Error details

    E: /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb: subprocesso novo script pre-installation retornou erro do status de saída 1
    "
    i close the window and other pop

    " update is not completed (...)

    i couldn't copy the text soo i print screen it
    "



    i hope you can understand sorry my english,
    waiting for help
    thanks

  7. #7
    Join Date
    May 2010
    Posts
    11

    Default

    Hi, a month ago i had the same problem but with Kano's code it work, but now i update to ubuntu 10.4 and i can't turn on the "Meny->System->Preferences->"Appearence"" (portuguese ubuntu don't know the english word), so i wnet to hardware and drivers menu and it said to Activate the driver FGLRX ATI/AMD but i got this whindow:

    SystemError: installArchives() failed

    ALSO in update manager i have an update "fglrx(new instalation)" and when i try to install i got this error: (I will try to translate the best i can)
    first i got this window:
    "you have 1 broken package in your system ! use the filter "broken" to trace then."
    i close the window and then it star to install but pop other window:
    "Error details

    E: /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb: subprocesso novo script pre-installation retornou erro do status de saída 1
    "
    i close the window and other pop

    " update is not completed (...)
    i couldn't copy the text soo i print screen it
    "



    i hope you can understand sorry my english,
    waiting for help
    thanks

  8. #8
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    The problem is when you run the ati-installer purely on U and then install fglrx via jockey/apt your system will break. Somebody reported that my script fixed it. Be sure that you NEVER run the ati installer on U again. Only via

    http://kanotix.com/files/install-fglrx-debian.sh

  9. #9
    Join Date
    May 2010
    Posts
    11

    Default

    i don't understand what you mean, i'm really dump on linux, could you tell me the what i have to do or write to resolve this problem? like i said in version 9.4 i had that unsupported watermark, i download the last driver, install with a command and do that code in console, saw this in a post of yours.
    now i update to 10.4 in update manager, and i have this error of "broken package" and fglrx update dont install. i already try do:

    sudo apt-get -f install

    but it dont work:

    "magrinho@magrinho-laptop:~$ sudo apt-get -f install
    [sudo] password for magrinho:
    A ler as listas de pacotes... Pronto
    A construir árvore de dependências
    A ler a informação de estado... Pronto
    A corrigir dependências... Feito
    Os seguintes pacotes foram instalados automaticamente e já não são necessários:
    linux-headers-2.6.31-14 fakeroot fglrx sdparm libqtcore4 dkms fglrx-amdcccle
    openoffice.org-hyphenation python-pysqlite2 libqtgui4 patch
    linux-headers-2.6.31-14-generic libaudio2
    Utilize 'apt-get autoremove' para os remover.
    Os seguintes pacotes extra serão instalados:
    fglrx
    Serão instalados os seguintes NOVOS pacotes:
    fglrx
    0 pacotes actualizados, 1 pacotes novos instalados, 0 a remover e 0 não actualizados.
    1 pacotes não totalmente instalados ou removidos.
    É necessário obter 0B/18,2MB de arquivos.
    Após esta operação, serão utilizados 60,0MB adicionais de espaço em disco.
    Deseja continuar [Y/n]? y
    (A ler a base de dados ... 173431 ficheiros e directórios actualmente instalados.)
    A descompactar fglrx (desde .../fglrx_2%3a8.723.1-0ubuntu3_i386.deb) ...

    [Warning] Uninstall : inst_path_default or inst_path_override
    does not exist in /etc/ati. This suggests that the ATI driver
    is not installed, the ATI driver is only partially installed,
    or the current ATI driver installed is an older version than the
    one this script was designed for. Both files listed above are
    required for determining where installed files are located.
    To force uninstallation of the driver by guessing where the
    uninstallation files are located, set the FORCE_ATI_UNINSTALL
    environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

    dpkg: erro ao processar /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb (--unpack):
    subprocesso novo script pre-installation retornou erro do status de saída 1
    Foram encontrados erros enquanto processava:
    /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    magrinho@magrinho-laptop:~$
    "
    thanks for helping me.

  10. #10
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    export FORCE_ATI_UNINSTALL=1

    then try again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •