Results 1 to 3 of 3

Thread: AMD Catalyst Driver Freezes Display

  1. #1
    Join Date
    Jan 2009

    Default AMD Catalyst Driver Freezes Display

    I've been suffering from this since the dawn of time (or 2 years ago). I'd love to know if it's a bug in the driver or if I'm doing something wrong.

    When I'm running with the Catalyst driver (any version, including the current one), switching from the X server to a console (ie. ctrl-alt-F1) and then back to the X server causes the display to freeze at the console and become unresponsive. Nothing fixes this, I have no choice but to turn off the computer and re-start it to get a usable system again. I used to think this was due to some weird hardware combination, but I recently changed from an all-AMD system to an Intel motherboard/cpu and it STILL DOES IT! It happened on my old 790G motherboard (onboard HD3300 graphics), with my HD4350 card, and with my HD4670 card. Now it's happening with an X-48 motherboard, Core2 Duo processor and HD4350 video card.

    That one issue has always driven me back to the radeonhd driver. I don't care much for 3D, so the radeonhd driver has always served me well. Besides, I got way better 2D performance out of it than I ever did with the Catalyst driver. But I just upgraded to opensuse 11.2, which includes the radeonhd 1.3 driver and now I'm getting all kinds of horrible artifacts on the desktop as I move my mouse cursor around. I wanted to give the Catalyst driver a chance again, and I got the same frozen-console issue again!!!

    What's going on? Could a bug this blatant and obvious really have lasted this long without getting fixed? It boggles the mind!!!
    Last edited by GoremanX; 11-02-2009 at 08:43 PM.

  2. #2
    Join Date
    Aug 2007


    Could be distro specific too - i could use console without problems, just shutting down kdm was often impossibe.

  3. #3
    Join Date
    Jun 2009


    I had the same problem with Catalyst driver. It took me long to get it. Once I tried to remove radeon framebuffer driver from kernel and it got fixed. I didn't need it, VESA fb worked well enough.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts