Page 53 of 117 FirstFirst ... 343515253545563103 ... LastLast
Results 521 to 530 of 1167

Thread: AMD's UVD2-based XvBA Finally Does Something On Linux

  1. #521
    Join Date
    Jun 2009
    Location
    Paris
    Posts
    428

    Default xvba-video 0.6.6

    A new version of xvba-video, the XvBA backend to VA-API, is now available at:
    http://www.splitted-desktop.com/~gbe...ne/xvba-video/

    Version 0.6.6 - 11.Feb.2010
    * Fix XvBA objects destruction for fglrx >= 8.70.3
    * Fix vaPutImage() to a surface used for decoding
    * Fix vaGetImage()/vaPutSurface() with surface dimensions not a multiple of 16
    * Fix rendering of VA subpictures that were previously deassociated

    The third change is actually two different workarounds for a single and major flaw in XvBA. I have not fully regression tested but this looks OK for MPlayer, Gnash and VLC. This should fix Kano problems.

    The fourth change is a fix for MPlayer/VA-API with ASS support, and that I will probably upload tomorrow. I have to check against the latest Intel drivers first. NVIDIA is already fine.

    Regards,
    Gwenole.

  2. #522
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    vlc 1.1 git works now with vaapi + xvba-video, but it crashes at the end of the movie.

  3. #523
    Join Date
    Apr 2007
    Location
    Hungary
    Posts
    84

    Default

    If anyone interested, I've filed a bugreport about Evergreen r800 UDV2 catalyst 10.1 problem here: http://ati.cchtml.com/show_bug.cgi?id=1754 . Vote / comment pls, if you feel like.

  4. #524
    Join Date
    Jun 2009
    Location
    Paris
    Posts
    428

    Default MPlayer/VAAPI 2010/02/12

    Hi,

    I have uploaded a new snapshot of MPlayer/VAAPI:
    http://www.splitted-desktop.com/~gbe...mplayer-vaapi/

    Version 2010.02.12
    * Fix YV12 rendering for SW codecs
    * Add EOSD support (ASS subtitles)
    * Add compatibility with original VA-API 0.29
    * Add support for -geometry +xxx+yyy (Adam Strzelecki)

    For EOSD & AMD, you need xvba-video >= 0.6.6.

  5. #525
    Join Date
    Aug 2009
    Posts
    150

    Default

    I tested it with my graphic card and it actually worked. Using Ubuntu 9.10 and fglrx 10.1.

    $ lspci | grep VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600XT]

    I used pre-built packages from http://www.splitted-desktop.com/~gbe...mplayer-vaapi/.

    The planet earth clip wasn't really playable as it was lagging and had quite a lot of disturbances.
    Big Buck Bunny played really well but sometimes, during short intervals, got a purple hue.
    Another clip (720p) I had lying around also work quite well but might have had slightly strange colours.

  6. #526
    Join Date
    Nov 2009
    Posts
    22

    Default

    Is it possible to use something like mplayer -vo vaapi:gl:deint=2 -va vaapi -fs <video>.ts to deinterlace astra hd promo channel? I'm getting a lot of error messages and no picture:

    Code:
    xvba_video: XVBA_TransferSurface(): status 215/115 10%  5% 16.6% 9 0 27%
    [vo_vaapi] vaCopySurfaceGLX(): operation failed
    xvba_video: XVBA_TransferSurface(): status 217/117 10%  5% 17.2% 9 0 27%
    [vo_vaapi] vaCopySurfaceGLX(): operation failed
    GPU Chipset is 785G (RS880)
    Karmic 32bit
    fglrx 10.1
    libva: libva version 0.31.0-sds4
    vainfo: VA API version: 0.31
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA API - 0.6.6

    It runs fine without deint=2, not deinterlaced then ...

  7. #527
    Join Date
    Jun 2009
    Location
    Paris
    Posts
    428

    Default

    Quote Originally Posted by Tuxoholic View Post
    Is it possible to use something like mplayer -vo vaapi:gl:deint=2 -va vaapi -fs <video>.ts to deinterlace astra hd promo channel? I'm getting a lot of error messages and no picture
    Deinterlacing is broken in XvBA. It's the second most critical bug that has to be fixed by the end of April.

  8. #528
    Join Date
    Nov 2009
    Posts
    22

    Default

    I see, thanks for the info gbeauche - will there be more inbuilt deinterlace strategies like "linear blend" in your upcoming release?

  9. #529
    Join Date
    Jun 2009
    Location
    Paris
    Posts
    428

    Default

    Quote Originally Posted by Tuxoholic View Post
    I see, thanks for the info gbeauche - will there be more inbuilt deinterlace strategies like "linear blend" in your upcoming release?
    Only bob deinterlacing at this time. More elaborated deinterlacers are not, and won't be, exposed to the public builds of xvba-video.

  10. #530
    Join Date
    Apr 2007
    Location
    Hungary
    Posts
    84

    Default

    http://support.amd.com/us/kbarticles...on-HD5400.aspx a beta. I've tested it with hd5650. No luck with the UVD2 / vaapi acceleration - still garbled output with evergreen. (Not that i was expecting it to be fixed in such a release, but i tested it nevertheless)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •