Results 1 to 5 of 5

Thread: Unknown boot option `radeon.agpmode=1'

  1. #1
    Join Date
    Oct 2007
    Posts
    48

    Default Unknown boot option `radeon.agpmode=1'

    Yesterday I installer Ubuntu 9.10. With my Mobility Radeon 9700 I always have to set AGPMode to 1, otherwise I'm getting freezes.

    It works if I create manually a xorg.conf, but as this config file is some kind of deprecated I was wondering if there has to be some other way.

    So I tried it with a boot option, but dmesg gives
    Code:
    [    0.000000] Unknown boot option `radeon.agpmode=1': ignoring
    .
    Though following modinfo radeon it seems to be a correct option...

    ...am I doing something wrong? Is there another more elegant way to set AGPMode to 1?

    Thanks a lot
    Ren

  2. #2
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,334

    Default

    If radeon is a module, instead of built into the kernel, the option would go to /etc/modprobe*

  3. #3
    Join Date
    Oct 2007
    Posts
    48

    Default

    radeon is not listed in /etc/modules and adding the option to /etc/modprobe.conf does not have any effect.
    As far as I understand, radeon ist loaded with the kernel (build in).
    Pelase correct if I'm drawing the wrong conclusions...

  4. #4
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by Ren Höek View Post
    radeon is not listed in /etc/modules and adding the option to /etc/modprobe.conf does not have any effect.
    As far as I understand, radeon ist loaded with the kernel (build in).
    Pelase correct if I'm drawing the wrong conclusions...
    I just did a quick test and the agpmode option only works if you are using kernel modesetting.

    I think ubuntu defaults to user modesetting so you'll still need to make an xorg.conf.

    If you are using kms then AFAIK with ubuntu you need to add a file to /etc/mod????/ containing a line like - options radeon agpmode=1
    then you have to run some command to update the database/something or it won't work.

    You may guess from the vagueness that I don't use ubuntu :-)

  5. #5
    Join Date
    Oct 2007
    Posts
    48

    Default

    Quote Originally Posted by legume View Post
    I just did a quick test and the agpmode option only works if you are using kernel modesetting.

    I think ubuntu defaults to user modesetting so you'll still need to make an xorg.conf.

    [..]
    Code:
    [drm] radeon default to kernel modesetting DISABLED.
    Well then, I will use the xorg.conf. I was just curious...

    Thanks all for the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •