Results 1 to 8 of 8

Thread: Software Rasterizer with and without KMS

  1. #1
    Join Date
    Jul 2008
    Posts
    77

    Default [SOLVED] Software Rasterizer with and without KMS

    Hello everyone.

    My drivers have fallen back to software rendering, with or without Kernel Modesetting enabled. As reported by glxinfo:

    OpenGL vendor string: Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string: 2.1 Mesa 7.6

    I've tried running with and without xorg.conf. Below are my current software versions (Arch Linux packaging):

    kernel26 2.6.31.6-1
    mesa 7.6-2
    ati-dri 7.6-2
    libgl 7.6-2
    xf86-video-ati 6.12.99.git20091014-1

    And my video card is:

    01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

    Please let me know what other information would be necessary to further debug this issue. Thank you.
    Last edited by aaaantoine; 11-13-2009 at 01:19 PM.

  2. #2
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Pastebin your dmesg and xorg log. You might also try:
    LIBGL_DEBUG=verbose glxinfo
    and see if that shows any lib-related problems.

  3. #3
    Join Date
    Jul 2008
    Posts
    77

    Default

    dmesg.log: (deleted, irrelevant)
    Xorg.0.log: (deleted, irrelevant)

    I don't know why the Xorg log says anything about prerelease. I got the package from Arch's standard repos, not testing or unstable.

    Both logs are with KMS enabled, and with no xorg.conf.

    Also, running LIBGL_DEBUG=verbose glxinfo I got this juicy bit:

    Code:
    libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/r300_dri.so
    libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/r300_dri.so    
    libGL error: failed to open drm device: Permission denied          
    libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
    Last edited by aaaantoine; 11-13-2009 at 01:22 PM.

  4. #4
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Make sure your user is in the video group (or whatever group your distro uses for 3D) so you have permission to use 3D.

  5. #5
    Join Date
    Jul 2008
    Posts
    77

    Default

    Ah... Yes, that did the trick. Thank you.

    Not sure why this problem hadn't manifested earlier (or maybe it has).

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    I had the same problem show up when I went from Ubuntu 9.04 to 9.10.

  7. #7
    Join Date
    Jul 2008
    Posts
    77

    Default

    I'm getting the software rasterizer again.

    - I found in my xorg.log that fbdev isn't loading because it "does not exist". I don't know if this is important.

    I also get
    Code:
    Error	RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
    ...immediately followed by...
    Code:
    Information	[dri] radeon kernel module version is 2.0.0 but version 1.17.0 or newer is needed.
    Information	[dri] Disabling DRI.
    Software versions have been updated since the original post. They are now...

    kernel26 2.6.31.6-1 (same as before)
    mesa 7.7-1
    ati-dri 7.7-1
    libgl 7.7-1
    xf86-video-ati 6.12.4-3

  8. #8
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Your xf86-video-ati is not built with kms support, but kms is enabled in the drm. xf86-video-ati 6.12.x does not support kms; you need git master. Boot with radeon.modeset=0 on the kernel command line to disable kms.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •