Results 1 to 7 of 7

Thread: Truly bad: gnome-settings-daemon + pulseaudio causing laptop HDD death

  1. #1
    Join Date
    Oct 2009
    Posts
    200

    Default Truly bad: gnome-settings-daemon + pulseaudio causing laptop HDD death

    Hi all,

    I'm using fedora 11 x64 with all updates on place.
    I'm really pissed off because I found that my laptop hard disk is parking the heads every 10 seconds circa, and gnome-settings-daemon is trying to start pulseaudio daemon every 10 seconds circa.

    This causes a deleterious parking/unparking job on the heads and raising the infamous Load_Cycle_Count HDD smart parameter. There was a famous issue with this counter (ubuntu people should remember this): manufacturers tell you that you disk is gonna die when it reaches a value between 300k-600k.

    How I found the issue?
    Installed atop, I saw that kjournald was invoked every 10 seconds, so I did:

    Code:
    > echo 1 >/proc/sys/vm/block_dump
    This command enables dumping of writes on block devices that you can see invoking dmesg. So I was able to identify that gnome-settings-daemon is writing periodically to a file (pulse-shm-xxxxxx).
    I got tons of lines like this:

    Code:
    gnome-settings-(11959): dirtied inode 188241 (pulse-shm-2392701627) on tmpfs
    Nice to see, pulseaudio is back...

    I killed gnome-settings-daemon and FINALLY got no periodic writes to disk.
    Now I want to ask everyone, gnome devs, pulseaudio devs, and normal people, how the hell I can sort this thing out? Can I finally disable pulseaudio? I dunno why PackageKit wants to tore my system apart if I try to uninstall pulseaudio.

    Bad bad bad guys, really bad.

  2. #2
    Join Date
    Apr 2008
    Location
    Saskatchewan, Canada
    Posts
    460

    Default

    Tmpfs is a RAM disk, isn't it?

    BTW, I haven't seen a load_cycle_count problem on my netbook running UNR 9.10.

  3. #3
    Join Date
    Oct 2009
    Posts
    200

    Default

    Nope, it isn't.

    gnome-settings-daemon creates and removes such files every 10 seconds in the try to start pulseaudio.

  4. #4
    Join Date
    May 2008
    Location
    Germany/NRW
    Posts
    510

    Default

    Quote Originally Posted by blackshard View Post
    Nope, it isn't.
    Uhm yes it is? But swap might be used as well if you're running low on memory.

  5. #5
    Join Date
    Oct 2009
    Posts
    200

    Default

    This is the entry in mtab:

    tmpfs /dev/shm tmpfs rw,rootcontext="system_ubject_r:tmpfs_t:s0" 0 0

    However I solved the problem, I just followed the guide here:

    http://forums.fedoraforum.org/showth...ettings-daemon

    and i finally reinstalled pulseaudio with a working setup.
    It still eats 30% of cpu cycles doing nothing, but at least I can use alsa output plugins easily without hanging the system.

    Also I monitored filesystem writes and gnome-settings-daemon is no more writing that file on disk (again, it was a disk write and not a ramdisk write).
    Also unistalling pulseaudio with yum remove uninstall didn't solve the problem, I had to reinstall it.

  6. #6
    Join Date
    May 2009
    Location
    Exodus hair
    Posts
    76

    Default

    Did You try adding a following line in /etc/fstab?
    Code:
    tmpfs        /tmp         tmpfs    defaults    0    0
    It helped me a lot in cutting disk access ... Thant way /tmp is in RAM and the only big problem is when You want to deal with large files in /tmp ...

  7. #7
    Join Date
    Oct 2009
    Posts
    200

    Default

    Thank you very much, I'll try the suggestion, I think it will be helpful too!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •