Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: Recommendations on Radeon card for Debian desktop.

  1. #21
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    http://cgit.freedesktop.org/xorg/dri...4628c055c47429

    This should fix this issue. Don't know why this did not happen with your card. My card:

    ATI Technologies Inc RV710 [Radeon HD 4550] [1002:9540] (prog-if 00 [VGA controller])
    Subsystem: ATI Technologies Inc Device [1002:2143]

    I see no fix for radeonhd yet.

  2. #22
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    It looks like it doesn't affect all monitors, so maybe my monitor is fine?

    Anyway, if there are issues with 4550 and some monitors, then perhaps it's not the best recommendation. I personally haven't had any trouble, so I didn't even know that such a problem existed.

  3. #23
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    It only affects some users/monitors. None of my cards or monitors exhibited the problem.

  4. #24
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    Well maybe you need a LG W2242T for your collection

  5. #25
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    If you're satisfied with the X1300, why not work on getting airflow over the heatsink? You could buy a quiet aftermarket cooler or be creative and find some way to get some airflow over it. EVen a little bit of airflow can make a significant difference in temps.

    I yes, can someone reccomend an HD card that is quiet, power efficient, and capable of driving a 1920x1200 DVI display?
    RadeonHD 4350/4550 is your best bet right now if you need a new card. I have a passively cooled Sapphire 4550.

  6. #26
    Join Date
    Aug 2006
    Posts
    90

    Default

    I have a HIS fanless HD4650 - http://www.hisdigital.com/un/product2-400.shtml. I got it from NewEgg almost a year ago. Sadly they no longer carry it. It works really well with fglrx since I got it (around 9.2) - the only thing that isn't flawless for me is a little tearing in video. Kwin's compositing works great, my gaming isn't very intense but everything I want works, etc.

    I've been playing around with the open drivers. It's almost ready to be used day-to-day with the OSS stack. I'd wager a couple more months and everything needed will be stable and in distro repositories. Of course to get the best 3D we'll be custom compiling for awhile.
    Last edited by Tillin9; 11-26-2009 at 01:34 AM.

  7. #27
    Join Date
    Aug 2007
    Posts
    6,641

    Default

    I really think fglrx users do not parallely own a system with nvidia

  8. #28

    Default

    Quote Originally Posted by DanL View Post
    If you're satisfied with the X1300, why not work on getting airflow over the heatsink? You could buy a quiet aftermarket cooler or be creative and find some way to get some airflow over it. EVen a little bit of airflow can make a significant difference in temps.


    RadeonHD 4350/4550 is your best bet right now if you need a new card. I have a passively cooled Sapphire 4550.
    Sorry for the tardy reply, as I was trying to do what you suggested. As an experiment I did have a 80mm fan positioned to blow air on the X1300's heatsink. Now it's super cool to the touch.

    But I'm getting the lockups in X that I was getting before. Playing with 3D xscreensavers eventually leads to X freezing. I can still move the X cursor. Can't swicth to a console either. It happens when I watch flash videos in fullscreen using FF 3.5 as well. I can SSH and kill X.

    So, how do I figure this out? Or should I get a new card. All the details of my system are in my first post.

    Here is some output from dmesg after killing X:
    [38683.324341] Pid: 16591, comm: skytentacles Not tainted (2.6.30-1-686 #1) System Product Name
    [38683.324344] EIP: 0060:[<f81160a3>] EFLAGS: 00210246 CPU: 1
    [38683.324351] EIP is at radeon_read_ring_rptr+0x1b/0x1e [radeon]
    [38683.324353] EAX: f4dc3340 EBX: f6963400 ECX: 0000000a EDX: 00000000
    [38683.324355] ESI: f8b7a000 EDI: f68b8800 EBP: f6fe5534 ESP: f56fbdfc
    [38683.324358] DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
    [38683.324361] Process skytentacles (pid: 16591, ti=f56fa000 task=c3e08df0 task.ti=f56fa000)
    [38683.324363] Stack:
    [38683.324364] f811672d f8b7a000 f6963400 f81175b7 f6963400 f68b8800 f8118eb6 00000008
    [38683.324369] f68b8800 f6994cf8 f8056837 00000008 f4e3abc0 f6994cf8 f6fe5534 c018e319
    [38683.324374] f70200c0 f4e3abc0 00000000 f69ce780 00000000 c018bb2c f69ce780 00000001
    [38683.324380] Call Trace:
    [38683.324382] [<f811672d>] ? radeon_commit_ring+0x47/0x91 [radeon]
    [38683.324392] [<f81175b7>] ? radeon_do_cp_idle+0x105/0x10e [radeon]
    [38683.324399] [<f8118eb6>] ? radeon_do_release+0x7f/0x187 [radeon]
    [38683.324406] [<f8056837>] ? drm_lastclose+0x31/0x232 [drm]
    [38683.324427] [<c018e319>] ? __fput+0xa6/0x135
    [38683.324432] [<c018bb2c>] ? filp_close+0x4e/0x54
    [38683.324436] [<c012855b>] ? put_files_struct+0x60/0xa6
    [38683.324441] [<c0129b8a>] ? do_exit+0x1a6/0x5b8
    [38683.324444] [<c0129ffa>] ? do_group_exit+0x5e/0x85
    [38683.324447] [<c01316fd>] ? get_signal_to_deliver+0x303/0x322
    [38683.324452] [<c0102623>] ? do_notify_resume+0x64/0x561
    [38683.324456] [<c012e55f>] ? lock_timer_base+0x19/0x35
    [38683.324460] [<c019721b>] ? vfs_ioctl+0x50/0x5f
    [38683.324464] [<c019766e>] ? do_vfs_ioctl+0x444/0x47f
    [38683.324468] [<f8057f58>] ? drm_handle_vblank+0x2c/0x2e [drm]
    [38683.324485] [<f81205a7>] ? radeon_driver_irq_handler+0xe6/0x11b [radeon]
    [38683.324493] [<c0111fda>] ? ack_apic_level+0x8f/0x165
    [38683.324497] [<c015be27>] ? handle_fasteoi_irq+0x90/0x97
    [38683.324502] [<c01976ea>] ? sys_ioctl+0x41/0x58
    [38683.324505] [<c01031a4>] ? work_notifysig+0x13/0x1b
    [38683.324509] Code: 91 04 01 00 00 8b 40 10 83 c0 40 89 10 31 c0 c3 f6 80 1e 03 00 00 08 8b 80 e0 00 00 00 74 06 03 50 10 8b 02 c3 83 e2 fc 03 50 10 <8b> 02 c3 83 78 5c 00 74 07 31 d2 e9 d5 ff ff ff 66 83 b8 1c 03
    [38683.324535] EIP: [<f81160a3>] radeon_read_ring_rptr+0x1b/0x1e [radeon] SS:ESP 0068:f56fbdfc
    [38683.324543] CR2: 0000000000000000
    [38683.324545] ---[ end trace 46493598418d8ed4 ]---
    [38683.324548] Fixing recursive fault but reboot is needed!

    Gent's any help would be appreciated. You can ask for any logs as well.

  9. #29
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    For a long time the X screen savers (particularly the complex ones) have been the only thing that can hang up my system (3450 + open drivers). The hang only happens occasionally, but each time it hangs when exiting the screen saver.

    When I looked into the problems I found a lot of posts indicating that the problem was in the screensaver and happened on lots of different drivers. I'm not 100% convinced because I think I remember one hang when quitting out of a different 3D app, but I have to admit that in the last couple of months the *only* hang I have seen is with specific screen savers. Maybe the combination of a screensaver bug PLUS driver bug, not sure.

    Are you seeing hangs with anything other than the screensavers ?

  10. #30

    Default

    Quote Originally Posted by bridgman View Post
    For a long time the X screen savers (particularly the complex ones) have been the only thing that can hang up my system (3450 + open drivers). The hang only happens occasionally, but each time it hangs when exiting the screen saver.

    When I looked into the problems I found a lot of posts indicating that the problem was in the screensaver and happened on lots of different drivers. I'm not 100% convinced because I think I remember one hang when quitting out of a different 3D app, but I have to admit that in the last couple of months the *only* hang I have seen is with specific screen savers. Maybe the combination of a screensaver bug PLUS driver bug, not sure.

    Are you seeing hangs with anything other than the screensavers ?
    This has been a Linux household for the last 10 (if not more) years and I have never had X lockup on me with xscreensaver before; even the short time I used an Nvidia 7800 GTX and its proprietary drivers. And yes, as I stated earlier, I get lockups when I play flash videos in Firefox. I notice it when I play full screen flash videos of South Park, The Daily Show, and The Colbert Report. Sorry, I don't watch much TV. I don't even own one really.

    I have never had an issue with my earlier Sapphire x1300 (RV515) using the radeon driver. Yes, I'm using a x1300 (V516) with the radeonhd driver now, but that's because the radeon driver and this X1300 (RV516) gives me wicked artifact/sparklies.
    Last edited by nyc_paramedic; 12-01-2009 at 11:49 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •