Results 1 to 9 of 9

Thread: Ubuntu To Stop Supporting LPIA Architecture

  1. #1
    Join Date
    Jan 2007
    Posts
    13,426

    Default Ubuntu To Stop Supporting LPIA Architecture

    Phoronix: Ubuntu To Stop Supporting LPIA Architecture

    Two years ago Ubuntu began supporting LPIA, or the Low-Power Intel Architecture. LPIA is i386, but with different compile-time optimizations...

    http://www.phoronix.com/vr.php?view=NzczOA

  2. #2
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    Useless effort anyway, i don't think that it was usefull at all. Packages which could be compiled with cpu optimisations like mplayer are outdated in all cases and have to be recompiled anyway. For a standard package you gain usually nothing.

  3. #3
    Join Date
    Feb 2008
    Location
    127.0.0.1
    Posts
    89

    Default

    That's why I use Gentoo
    Yes it is nontrivial at least to maintain Gentoo installation even for experienced user.
    With current level of HW performance, compilation time is not an issue.
    IMHO, Sabayon is a step toward ultimate OS for average user.
    It is polished and configured out of the box on the same level as any mainstream binary distribution (Ubuntu, OpenSUSE, Fedora).
    It takes minutes to install (no longer or more complicated then Ubuntu).
    But what makes the difference is that Sabayon is 100% Gentoo compatible.
    What it means, that you can safely rebuild the packages.
    The only recommendation is not to change global use flags.
    IMHO, this is the future. Rolling distribution, highly optimized, but not visible to the user.
    The performance gains could be x4 times over prebuilt binaries like Ubuntu. After all, binary distributions use lowest common denominator which is usually Pentium Pro for 32bit. And this is decade old HW that can't do anything useful on the desktop.
    64bit situation is better, but still, has not changed much since first AMD 64bit processors.

  4. #4
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    Sabayon should look at SuSE, there is syslinux with gfxboot patch in a version that supports isohybrid mode. Currently they use completely outdated syslinux without. Therfore you can not put it 1:1 onto usb. A rolling distribution is nice for freaks, but it is not the future. I supported this for 3 years and every day it could break a part (Debian sid not Gentoo). You can not plan when something will change - from users point of view this does not matter or when you do it for your own, but when you want to support lots of users it is not funny. You also have got no time to really fix major things.

  5. #5
    Join Date
    Feb 2008
    Location
    127.0.0.1
    Posts
    89

    Default

    OK, lets separate things.
    You can use "stable" rolling and "not so stable" on Gentoo.
    The trick with "multislot" solves a lot of problems.
    Actually, I'm not against scheduled releases of "base system"
    but stuff like browser, media player, and other non critical user apps should be rolling.
    I don't want to wait 6 month to see the newest browser or OOO.
    It is hard to call Linux desktop "Bleeding Edge" when you are the last to see cross platform software.
    What happens in real world, only minor version updates available.
    To get the new stuff, you have to add repos etc - not an option for average user.
    PPA or overlays not maintained good enough and tend to disappear

  6. #6
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    Well your examples are not that good First of all you get deb/rpm/tar from http://www.openoffice.org/ - i put em into a repository - then it is really easy to update. For the webbrowser it is just needed to extract any official tar.gz in your home. That works even for snapshots to try em without hurting the rest of the system. mplayer should be compiled as snapshot, but thats only one package - i even provide scripts for svn default, vaapi enabled or mt branch...

  7. #7
    Join Date
    Feb 2008
    Location
    127.0.0.1
    Posts
    89

    Default

    Hm ...
    Let's see ...
    Everyone provides deb AND rpm ? i know that you can use "alien" ...
    But, try to explain it to my 70 years old stepfather.
    Let's say he installed Skype or Picassa from the web site in one click ...
    You can't expect him to remember to update all "non official repo" packages. In Windows you at least notified that "update available".
    Or "only one package to compile, SVN, dependencies, libraries" ...
    He just wants to watch some VC-1 1080p movie ...
    He does not know what VDPAU is.
    I was frustrated to install something with VDPAU support on his Ubuntu.
    It took me less time to switch him to Sabayon
    and I'm talking about couple of months ago.
    So it took me a while to teach him how to use Synaptic for Add/Remove programs.
    Non of the current ways is perfect.
    Gentoo/Sabayon in my experience gives you the most comprehensive official installation source. Games (ET, ETQW,DOOM, DOOM 3,Quake-Quake 4 and many others), Skype, Picassa, Nero etc.
    Numbers are confusing since in Portage number of packages is about half of what you have in Ubuntu.
    But remember those *-dev packages ?
    Or even better. Only ONE package to install to get OOO. In ubuntu it's 10-20-30 ?
    And one very funny example ...
    Ubuntu 64 uses 32 bit flash that recently stopped to work with some flash controls in games. 64 bit flash plugin available ~year.
    Try to remove ubufox.
    And so on ...
    I started experimenting with Sabayon on my mom's laptop. After trying Ubuntu/Debian... Guess what, even without rebuilding it worked much better.
    And no frustrations with Skype sound, flash videos etc. (that's the main part of her usage). Other option was to cleanup XP. I don't want to spend time on maintaining computers. For some people they should just work.

  8. #8
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    In order to use vdpau you have to use an optimized config file. I am sure that's not provided by default. So if you are a noob you have got lost without help anyway.

  9. #9
    Join Date
    Feb 2008
    Location
    127.0.0.1
    Posts
    89

    Default

    Yes and no
    If you use XBMC to watch the media, it just works
    Mplayer on the other hand must be configured to use VDPAU.
    But this is less important
    The point of this article is stopping to support some features in binary distribution (Ubuntu).
    In source distribution, it is just configuration.
    And always latest and greatest
    Neither is perfect but IMHO Sabayon in right direction to provide perfect OS
    As time goes on, the gap between latest HW and lower common denominator will grow. So "one size fit all" will punish some people. Since Linux distributions tend to support older HW rather optimize for new, I don't like that my money paid for useless silicon circles

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •