Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: 8.28.8 3D acceleration

  1. #11

    Default

    Not too sure about the screensavers, I haven't had any problems myself.

    Multiple people have reported slow-downs in glxgears with recent drivers, while the real-world performance largely hasn't been effected.

    Are you using the most recent version of Cedega? It should largely fix the ATI fglrx issues.

  2. #12
    Join Date
    Aug 2006
    Posts
    12

    Default

    Quote Originally Posted by Michael View Post
    Not too sure about the screensavers, I haven't had any problems myself.

    Multiple people have reported slow-downs in glxgears with recent drivers, while the real-world performance largely hasn't been effected.

    Are you using the most recent version of Cedega? It should largely fix the ATI fglrx issues.
    Okay I'll try the latest Cedega when I can get my hands on it. Thanks for your quick help , I will get back to you as soon as something new develops.

  3. #13
    Join Date
    Aug 2006
    Posts
    12

    Default

    Ahh, just a quick question, i just ran the screensaver which i'm having trouble with with LIBGL_DEBUG=verbose kcometen3.kss

    and this is what it tells me:

    [root@Fedora ~]# LIBGL_DEBUG=verbose kcometen3.kss
    libGL: XF86DRIGetClientDriverName: 8.28.8 fglrx (screen 0)
    libGL: OpenDriver: trying /usr/lib/dri/fglrx_dri.so
    libGL error: dlopen /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)
    libGL error: unable to load driver: fglrx_dri.so

    Any ideas?
    Last edited by Merlinux; 08-31-2006 at 02:13 AM.

  4. #14

    Default

    Hi Merlinux,

    First of all, glxgears is hardly any indication of real world performance and even worse, glxgears isn't really designed to be used for ATi hardware, so you cannot really test the capability your ATi accelerated card. fgl_glxgears would be more apt but still not indicative of any real world performance.

    The only real way to test your performance is by running actual games. If Quake 3 runs at a stable 60 to 90 frames per second, then rest assured that your card and driver is working fine.

    As far as the screen saver error goes, it seems like you have some version mismatch with some of the modules installed with your ATi drivers. Did you do any file replacements as I think that's a common cause of problems.

  5. #15
    Join Date
    Aug 2006
    Posts
    12

    Default

    Quote Originally Posted by niniendowarrior View Post
    Hi Merlinux,

    First of all, glxgears is hardly any indication of real world performance and even worse, glxgears isn't really designed to be used for ATi hardware, so you cannot really test the capability your ATi accelerated card. fgl_glxgears would be more apt but still not indicative of any real world performance.

    The only real way to test your performance is by running actual games. If Quake 3 runs at a stable 60 to 90 frames per second, then rest assured that your card and driver is working fine.

    As far as the screen saver error goes, it seems like you have some version mismatch with some of the modules installed with your ATi drivers. Did you do any file replacements as I think that's a common cause of problems.

    Well initially, no. I performed a fresh install and upgraded the kernel, then installed the corresponding ATI drivers using the buildpkg way. When I then try to install kcometen it tells me i'm missing glu.h, so I found such a file and copied it to the directory, it bypassed that error, then told me i didn't have LibGLU.so, again I found such a file and copied it to where it should usually be. The screensaver then compiles and installs without any errors. But it just doesn't run smoothly at all.

    [root@Fedora ~]# LIBGL_DEBUG=verbose kcometen3.kss
    libGL: XF86DRIGetClientDriverName: 8.28.8 fglrx (screen 0)
    libGL: OpenDriver: trying /usr/lib/dri/fglrx_dri.so
    libGL error: dlopen /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)
    libGL error: unable to load driver: fglrx_dri.so

  6. #16

    Default

    I have no concrete proof, but I'm inclined to blame your libGLU for your problems.

    I think it's too much a related module to fglrx to just simply paste into. And it may cause some mayhem for your fglrx.

  7. #17
    Join Date
    Aug 2006
    Posts
    12

    Default

    Quote Originally Posted by niniendowarrior View Post
    I have no concrete proof, but I'm inclined to blame your libGLU for your problems.

    I think it's too much a related module to fglrx to just simply paste into. And it may cause some mayhem for your fglrx.
    Well I'm inclined to agree, since I just nonchalantly copied the libGLU file over. Without it however, the screensaver would not compile at all.
    Do you possibly know what package I could install that would properly install the missing components, such as libGLU.so and glu.h among others which I'm sure are missing?

  8. #18

    Default

    Sure.

    Normally, that .so file is supplied by MesaGL. I think, though, that fglrx supplies it's own headers and shared objects. Since I'm not entirely sure what fglrx includes, you'd better check on what it installs. But libGLU should be part of MesaGL, or OpenGL for that matter.

    Here's a neat link that clearly shows you what package supplies libGLU.
    http://rpm2html.osmirror.nl/libGLU.so.1.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •