Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: numerious install and execution problems

  1. #1
    Join Date
    Nov 2009
    Posts
    33

    Default numerious install and execution problems

    OK, so I did a install-all and many tests could not be installed

    either bad checksums, or non existent file/files.

    When running universe or universe-x the system or pts will eventually hang, additionally several tests will fail to run.

    I attribute the failures to incompatible hardware.

    So the issue is a fix or method need to be incorporated so that tests that can't run for what ever reason won't be, this way test that can be executed can and will be and results can be collected.

    Is there any methods I can utilize to avoid system hangs or pts core failures?

    thanks
    Last edited by toddbailey; 11-28-2009 at 08:42 PM.

  2. #2

    Default

    Hi Todd,

    Are you able to comment more on these problems you are experiencing with PTS eventually hanging? If a test fails to run, PTS should automatically continue on running with the next test, but not hang. I haven't ever encountered such. If you can comment more on the problem I can tell you how to address it or if there is a bug in pts-core to get that resolved.

    -- Michael

  3. #3
    Join Date
    Nov 2009
    Posts
    33

    Default

    OK I'll respond in 4 separate posts 2 for install and 2 for execution, across 2 different machines


    first machine is a dell d800 laptop w 1.6 g cpu, 2 gig mem, nv 4200 64 meg video


    install summary:

    The following tests failed to install:

    - build-php
    - encode-ape
    - espeak
    - gnupg
    - memory-bandwidth
    - n-queens
    - nero2d
    - qgears2

    I have archives of the full install output that I'd like to submit,
    and later on the output of the test runs, but I don't see a way to attach a file to a posting,
    plz advise

  4. #4

    Default

    What Linux distribution and PTS release? You can send logs to michael [at] phoronix.com

  5. #5
    Join Date
    Nov 2009
    Posts
    33

    Default

    opps Sorry,


    the laptop...

    b$ phoronix-test-suite system-info

    ====================================
    Phoronix Test Suite v2.2.0 (Bardu)
    System Information
    ====================================

    PHP Notice: Undefined offset: 1 in /usr/share/phoronix-test-suite/pts-core/objects/phodevi/phodevi_gpu.php on line 568
    Hardware:
    Processor: Intel Pentium M 1600MHz @ 1.60GHz (Total Cores: 1), Motherboard: Dell 01W890, Chipset: Intel 82855PM to I/O + ICH4-M, System Memory: 2014MB, Disk: 80GB TOSHIBA MK8025GA, Graphics: GeForce4 4200 Go/AGP/SSE2, Monitor: Sharp

    Software:
    OS: Fedora 11, Kernel: 2.6.30.9-96.fc11.i586 (i686), Desktop: GNOME 2.26.3, Display Server: X.Org Server 1.6.3.901 (1.6.4 RC 1), OpenGL: 1.5.8 NVIDIA 96.43.14, Compiler: GCC 4.4.1, File-System: ext4, Screen Resolution: 1280x1024

  6. #6
    Join Date
    Nov 2009
    Posts
    33

    Default

    and the desktop

    phoronix-test-suite system-info

    =====================================
    Phoronix Test Suite v2.0.0 (SANDTORG)
    System Information
    =====================================

    Hardware:
    Processor: AMD Athlon 64 X2 Dual Core 6400+ @ 3.20GHz (Total Cores: 2), Motherboard: ASUSTeK M2N4-SLI, Chipset: AMD K8, System Memory: 4025MB, Disk: 400GB WDC WD4000YR-01P + 400GB ST3400633AS + 400GB Maxtor 6H400F0, Graphics: GeForce 8800 GT 512MB (660/950MHz)

    Software:
    OS: Fedora release 11 (Leonidas), Kernel: 2.6.30.9-96.fc11.i686.PAE (i686), Desktop: GNOME 2.26.3, Display Server: X.Org Server 1.6.3.901 (1.6.4 RC 1), OpenGL: 3.0.0 NVIDIA 185.18.36, Compiler: GCC 4.4.1, File-System: ext3, Screen Resolution: 1920x1080

  7. #7
    Join Date
    Nov 2009
    Posts
    33

    Default

    looks like I need to upgrade the desktop

    consider it done

  8. #8

    Default

    Hi Todd,

    Below are notes after looking at your logs:

    QGears2 - You seem to be missing some Qt4 libraries/header files. On Ubuntu and most distributions they should be automatically installed if you are prompted for the root password during the install process. With Fedora I think it should be fetching most of them, but if you can find what Qt4 package is missing, please let me know.

    Warsow - The missing libcurl.so.3 may or may not be fixable depending upon your distribution. Some of the newer distributions are not shipping with libcurl.so.3, but the .4 version instead. Mostly just waiting on a new upstream Warsow release to address it.

    Planet Penguin Racer - Need to look into it, may be an upstream issue.

    GLMark - seg fault is an upstream issue with it.

    build-php - The PHP mirrors sadly lost the 5.2.9 copy, but new URLs should be found in Git.

    GnuPG - The test profile is sort of broken right now, waiting on patches from the person that broke the profile.

  9. #9
    Join Date
    Nov 2009
    Posts
    33

    Default

    here is a fix for the libcurl isssue

    # cd /usr/lib
    # ln -s libcurl.so.4 libcurl.so.3
    # ldconfig

    the warsow test now runs

  10. #10
    Join Date
    Nov 2009
    Posts
    33

    Default

    Did you examine the execution log file yet?

    the machine d800 has several failure points before completely hanging forcing a power off to reset

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •