Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 54

Thread: Radeon DRM Power Management Moves Along

  1. #11
    Join Date
    Jan 2010
    Posts
    7

    Question

    These patches do apply, but during kernel compilation they block depmod (without patches all compilation work).
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV730_me.bin
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV710_pfp.bin
    INSTALL /home/yimm/compilation/kernel-pm-patches/pkg/lib/firmware/radeon/RV710_me.bin
    DEPMOD 2.6.33-rc4-rc
    And nothing...
    Ideas?

  2. #12
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    Patches can not block depmod. Just wait longer for it to finish.

  3. #13
    Join Date
    Jan 2010
    Posts
    7

    Default

    But I have already waited 15 minutes, and always at the same step; Without them, it takes 1-2 seconds
    So I will retry by waiting more time.
    Last edited by yimm; 01-19-2010 at 09:00 AM.

  4. #14
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    950

    Default

    First patch is already in drm-radeon-testing.

    How to check if it really downclok the gpu/memory?

  5. #15
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    Quote Originally Posted by darkbasic View Post
    First patch is already in drm-radeon-testing.

    How to check if it really downclok the gpu/memory?
    cat /sys/kernel/debug/dri/0/radeon_pm_info

  6. #16
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    950

    Default

    Groan... I forgot to enable kernel debugging :-(

  7. #17
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    950

    Default

    I enabled kernel debugging but /sys/kernel/debug/ is still empty.

  8. #18
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    mount -t debugfs none /sys/kernel/debug/

  9. #19
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    950

    Default

    gentoo niko # cat /sys/kernel/debug/dri/0/radeon_pm_info
    state: PM_STATE_DISABLED
    default engine clock: 776000 kHz
    current engine clock: 769500 kHz
    default memory clock: 1126000 kHz
    current memory clock: 1125000 kHz

    Then I loaded nexuiz after typing:

    gentoo niko # sleep 60 && cat /sys/kernel/debug/dri/0/radeon_pm_info
    state: PM_STATE_DISABLED
    default engine clock: 776000 kHz
    current engine clock: 769500 kHz
    default memory clock: 1126000 kHz
    current memory clock: 1125000 kHz

    Clocks are still the same.
    Anyway, how to change the state? What's PM_STATE_DISABLED?

  10. #20
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    Quote Originally Posted by darkbasic View Post
    gentoo niko # cat /sys/kernel/debug/dri/0/radeon_pm_info
    state: PM_STATE_DISABLED
    default engine clock: 776000 kHz
    current engine clock: 769500 kHz
    default memory clock: 1126000 kHz
    current memory clock: 1125000 kHz

    Then I loaded nexuiz after typing:

    gentoo niko # sleep 60 && cat /sys/kernel/debug/dri/0/radeon_pm_info
    state: PM_STATE_DISABLED
    default engine clock: 776000 kHz
    current engine clock: 769500 kHz
    default memory clock: 1126000 kHz
    current memory clock: 1125000 kHz

    Clocks are still the same.
    Anyway, how to change the state? What's PM_STATE_DISABLED?
    You have to enable it using dynpm parameter (dynpm=1). You can set this on loading module time (modprobe radeon dynpm=1), or in GRUB (radeon.dynpm=1) or in /etc/modprobe.d/some.file

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •